summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 01:34:02 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 01:34:02 +0200
commit5b886899330fdddf3798b03016a01fc973d768cc (patch)
treefe21f8de0038ade0a51703efd3320412ab90a862
parentc46ea41c016bbd1329a3f29f83f1dd0c11bddcaf (diff)
gnu: openssl: Explicitly declare the _FILE_OFFSET_BITS we want.
* gnu/packages/tls.scm (openssl)[arguments]<#:phases>[ensure-file-offset-bits-64]: Explicity declare the _FILE_OFFSET_BITS we want.
-rw-r--r--gnu/packages/tls.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index d60eeea692..b9f7fd236b 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -354,6 +354,11 @@ required structures.")
"linux-aarch64")))
#t)))
'())
+ (add-before 'configure 'ensure-file-offset-bits-64
+ ;; Note: lib/gl/sys/types.h has off_t, but only for Windows.
+ (lambda _
+ (setenv "CFLAGS" "-D_FILE_OFFSET_BITS=64")
+ #t))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))