summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-20 23:11:55 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-20 23:56:17 +0200
commit855bc05e118913ddc5d4c544a77a2f82c9df929c (patch)
tree13ca4605899343aa440c3bed9af65f2ac13c38da
parent3b49071fd1ee3e995900ea87fbabeea4d8cf86c6 (diff)
gnu: glibc: Add version 2.31.
* gnu/packages/base.scm (glibc-2.31): New variable. * gnu/system/locale.scm (%default-locale-libcs): Add it.
-rw-r--r--gnu/packages/base.scm11
-rw-r--r--gnu/system/locale.scm2
2 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index fb60e3c99b..99ba427ccb 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -956,6 +956,17 @@ with the Linux kernel.")
;; Below are old libc versions, which we use mostly to build locale data in
;; the old format (which the new libc cannot cope with.)
+(define-public glibc-2.31
+ (package
+ (inherit glibc)
+ (version "2.31")
+ (source (origin
+ (inherit (package-source glibc))
+ (uri (string-append "mirror://gnu/glibc/glibc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05zxkyz9bv3j9h0xyid1rhvh3klhsmrpkf3bcs6frvlgyr2gwilj"))))))
+
(define-public glibc-2.30
(package
(inherit glibc)
diff --git a/gnu/system/locale.scm b/gnu/system/locale.scm
index 77a6ef8e46..4771192cfb 100644
--- a/gnu/system/locale.scm
+++ b/gnu/system/locale.scm
@@ -147,7 +147,7 @@ data format changes between libc versions."
(define %default-locale-libcs
;; The libcs for which we build locales by default.
- (list glibc))
+ (list glibc-2.31 glibc))
(define %default-locale-definitions
;; Arbitrary set of locales that are built by default. They are here mostly