summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-23 08:12:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-23 08:13:10 +0300
commit923bb70a1bff657125c3008f119a477e5cb57c2b (patch)
tree54006c01c707835e565a0575059fb1aed04099fc
parent73b67eeea45172fc40ab7be742d32ea09424c543 (diff)
gnu: glibc-for-bootstrap: Fix patch.
This is a follow-up to d08f5299e62ca8f5f36f4f6ddf3fcd739d157074. * gnu/packages/patches/glibc-bootstrap-system.patch: Update.
-rw-r--r--gnu/packages/patches/glibc-bootstrap-system.patch15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/patches/glibc-bootstrap-system.patch b/gnu/packages/patches/glibc-bootstrap-system.patch
index f40833960f..fcaf17132d 100644
--- a/gnu/packages/patches/glibc-bootstrap-system.patch
+++ b/gnu/packages/patches/glibc-bootstrap-system.patch
@@ -3,8 +3,10 @@ and popen(3) need to be tweaked to use the right shell. For the bootstrap
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
instead uses the hard-coded absolute file name of `bash'.
+In addition, status should be initialized to 0 and not -1.
+
diff --git a/libio/iopopen.c b/libio/iopopen.c
-index ebc381ed..e0d3ed1b 100644
+index ebc381ed7c..e0d3ed1bc3 100644
--- a/libio/iopopen.c
+++ b/libio/iopopen.c
@@ -85,7 +85,7 @@ spawn_process (posix_spawn_file_actions_t *fa, FILE *fp, const char *command,
@@ -17,9 +19,18 @@ index ebc381ed..e0d3ed1b 100644
(char *) command, NULL }, __environ) != 0)
return false;
diff --git a/sysdeps/posix/system.c b/sysdeps/posix/system.c
-index a03f478f..9530404e 100644
+index a03f478fc7..94da6facf3 100644
--- a/sysdeps/posix/system.c
+++ b/sysdeps/posix/system.c
+@@ -101,7 +101,7 @@ cancel_handler (void *arg)
+ static int
+ do_system (const char *line)
+ {
+- int status = -1;
++ int status = 0;
+ int ret;
+ pid_t pid;
+ struct sigaction sa;
@@ -145,7 +145,7 @@ do_system (const char *line)
__posix_spawnattr_setflags (&spawn_attr,
POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);