summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 15:17:07 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 15:17:07 +0200
commit988b189c07db3accd05c1bc8180488c14d970c99 (patch)
tree1f52a402dd6878d5fe258bbbfb85c17fa7b3622c
parent3c34647a6b4834f71db1c27fd0aeb963d3267888 (diff)
gnu: cmake-bootstrap: Explicity declare the _FILE_OFFSET_BITS we want.
* gnu/packages/cmake.scm (cmake-bootstrap)[arguments]<#:phases>[ensure-file-offset-bits-64]: Explicity declare the _FILE_OFFSET_BITS we want.
-rw-r--r--gnu/packages/cmake.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index cf3bc406bc..03b1ce05c2 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -190,6 +190,13 @@
#:phases
(modify-phases %standard-phases
,@%common-build-phases
+ (add-before 'configure 'ensure-file-offset-bits-64
+ (lambda _
+ ;; See <https://gitlab.kitware.com/cmake/cmake/-/commit/627fb15eaac5bc02c9bddfb0be85d4b4f38d4a3a>
+ ;; for justification.
+ (setenv "CFLAGS" "-D_FILE_OFFSET_BITS=64")
+ (setenv "CXXFLAGS" "-D_FILE_OFFSET_BITS=64")
+ #t))
(add-before 'configure 'set-paths
(lambda _
;; Help cmake's bootstrap process to find system libraries