summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-20 01:01:27 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-20 01:01:27 +0200
commitd2a01e3b5b39f2665c3c50be452cea1ae06785af (patch)
treeb659c53540ea70b0db1d854ef08a2277d3f554cb
parent18fa433bf5c420868562b9f4b017c5c97251a44b (diff)
gnu: glibc: Update to 2.32.
* gnu/packages/base.scm (glibc): Update to 2.32. [arguments]: Add #:make-flags.
-rw-r--r--gnu/packages/base.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f22e4ab9cc..fb60e3c99b 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -699,13 +699,13 @@ the store.")
;; version 2.28, GNU/Hurd used a different glibc branch.
(package
(name "glibc")
- (version "2.31")
+ (version "2.32")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/glibc/glibc-" version ".tar.xz"))
(sha256
(base32
- "05zxkyz9bv3j9h0xyid1rhvh3klhsmrpkf3bcs6frvlgyr2gwilj"))
+ "0di848ibffrnwq7g2dvgqrnn4xqhj3h96csn69q4da51ymafl9qn"))
(snippet
;; Disable 'ldconfig' and /etc/ld.so.cache. The latter is
;; required on LFS distros to avoid loading the distro's libc.so
@@ -797,6 +797,11 @@ the store.")
'("--disable-werror")
'()))
+ ;; Arrange so that /etc/rpc & co. go to $out/etc.
+ #:make-flags (list (string-append "sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))
+
#:tests? #f ; XXX
#:phases (modify-phases %standard-phases
(add-before