summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-09-11 11:39:34 -0400
committerMathieu Othacehe <othacehe@gnu.org>2020-09-18 22:26:33 +0200
commitd7f776888b1fa4a3d58d4d67a1f137c4291d8843 (patch)
treed460662204e78125589422266d6a6603eab0936c
parent66e3812e2fb152f9a98e85f7d74a92753a2873b8 (diff)
gnu: boost: Update to 1.74.0.
* gnu/packages/boost.scm (boost): Update to 1.74.0. [source]: Remove patches and defunct substitute. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/boost.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 6a08b0d6c7..d6bdefcf83 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -60,21 +60,15 @@
(define-public boost
(package
(name "boost")
- (version "1.72.0")
+ (version "1.74.0")
(source (origin
(method url-fetch)
(uri (string-append "https://dl.bintray.com/boostorg/release/"
version "/source/boost_"
(version-with-underscores version) ".tar.bz2"))
- (patches
- (list (boost-patch
- ;; 1.72.0 was released with a faulty coroutine submodule:
- ;; <https://github.com/boostorg/coroutine/issues/46>.
- "0001-revert-cease-dependence-on-range.patch" version
- "1zcqxzh56m1s635wqwk15j3zcs2gmjvjy2f0hid7i78s4pgm0yfs")))
(sha256
(base32
- "08h7cv61fd0lzb4z50xanfqn0pdgvizjrpd1kcdgj725pisb5jar"))))
+ "1c8nw4jz17zy2y27h7p554a5jza1ymz8phkz71p9181ifx8c3gw3"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)
("zlib" ,zlib)))
@@ -123,8 +117,7 @@
(out (assoc-ref outputs "out")))
(substitute* '("libs/config/configure"
"libs/spirit/classic/phoenix/test/runtest.sh"
- "tools/build/src/engine/execunix.cpp"
- "tools/build/src/engine/Jambase")
+ "tools/build/src/engine/execunix.cpp")
(("/bin/sh") (which "sh")))
(setenv "SHELL" (which "sh"))