summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-20 23:51:25 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-20 23:56:30 +0200
commitdd36f508d57edc09b71f2316969dc14fee7df2c2 (patch)
tree3af2935f814bd4293c4f32df80109a3f11b720ff
parent2a3fccf70f1a9f83b024106bbeffb85db688e6a9 (diff)
gnu: node: Update to 10.22.0.
* gnu/packages/node.scm (node): Update to 10.22.0. (node-10.22): Remove. It was referring to 'nghttp2-1.41', which is unbound.
-rw-r--r--gnu/packages/node.scm22
1 files changed, 2 insertions, 20 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index f0b989b88a..cfcd08e94f 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -48,14 +48,14 @@
(define-public node
(package
(name "node")
- (version "10.20.0")
+ (version "10.22.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nodejs.org/dist/v" version
"/node-v" version ".tar.xz"))
(sha256
(base32
- "0cvjwnl0wkcsyw3kannbdv01s235wrnp11n2s6swzjx95gpichfi"))
+ "1nz18fa550li10r0kzsm28c2rvvq61nq8bqdygip0rmvbi2paxg0"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -201,24 +201,6 @@ devices.")
(properties '((max-silent-time . 7200) ;2h, needed on ARM
(timeout . 21600))))) ;6h
-;; TODO: Make this the default node on core-updates. This cannot be done on
-;; master since this version of node requires a newer nghttp2 library at link
-;; time.
-(define-public node-10.22
- (package
- (inherit node)
- (version "10.22.0")
- (source (origin
- (inherit (package-source node))
- (uri (string-append "https://nodejs.org/dist/v" version
- "/node-v" version ".tar.xz"))
- (sha256
- (base32
- "1nz18fa550li10r0kzsm28c2rvvq61nq8bqdygip0rmvbi2paxg0"))))
- (inputs
- (alist-replace "nghttp2" (list nghttp2-1.41 "lib")
- (package-inputs node)))))
-
(define-public libnode
(package
(inherit node)