summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-24 13:05:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-24 15:21:04 -0400
commitdef6e2ae4619587114383b3f8fd9f3cf8310b4b9 (patch)
treee6f84ef7158c196b42ef294fa4116e699a921833
parent5cf6f6fe7b610e50d4f723f345799092d2b518ba (diff)
gnu: util-linux: Search for setuid helper programs as well.
To allow using mount as an unprivileged user, the helper commands must also be setuid. Before this change, the 'mount' command would only look under /run/current/profile/sbin. Extend the default path to include /run/setuid-programs as well. Partially addresses <https://issues.guix.gnu.org/39670>. * gnu/packages/linux.scm (util-linux)[configure-flags]: Prepend "/run/setuid-programs:" to the default search path. Reported-by: Nathan Dehnel <ncdehnel@gmail.com>
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 59ffb334e0..f635c2343c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1481,7 +1481,10 @@ providing the system administrator with some help in common tasks.")
"static")) ;2.9 MiB static .a libraries
(arguments
`(#:configure-flags (list "--disable-use-tty-group"
- "--enable-fs-paths-default=/run/current-system/profile/sbin"
+ (string-append
+ "--enable-fs-paths-default="
+ "/run/setuid-programs"
+ ":/run/current-system/profile/sbin")
;; Don't try to chown root:root mount and umount
"--disable-makeinstall-chown"
"--localstatedir=/var"