summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-09-17 11:47:55 -0400
committerMathieu Othacehe <othacehe@gnu.org>2020-09-18 22:26:33 +0200
commite364758d44bdbf767df7666febd03f2c939e4ee2 (patch)
tree8da017907c542df883c8847f43310713ecdf57cb
parent8944f1a4a4bfe65ad83d4926fbdbeb3e11ec7728 (diff)
gnu: openblas: Update to 0.3.10.
* gnu/packages/maths.scm (openblas): Update to 0.3.10. [source]: Fetch from github. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index df4d39f900..1ed1e0511b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3609,16 +3609,17 @@ parts of it.")
(define-public openblas
(package
(name "openblas")
- (version "0.3.9")
+ (version "0.3.10")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/openblas/v" version "/OpenBLAS%20"
- version "%20version.tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xianyi/OpenBLAS")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "14iz9xnrb9xiwgj84j94mc74gg0zn2vsy9fmsijxxma1n7dck4w3"))))
+ "174id98ga82bhz2v7sy9yj6pqy0h0088p3mkdikip69p9rh3d17b"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"