summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-18 18:38:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-18 18:57:59 +0200
commite94334391262a13b354d271be6f2977092dab511 (patch)
tree10662df3306f1f6c716f393c7584cd162c24fccc
parent7467f9857dc530861735ebffe2c9376c8dfb80b7 (diff)
gnu: cups-filters: Wrap with grep.
* gnu/packages/cups.scm (cups-filters)[inputs]: Add grep. [arguments]: Wrap all filters with it in $PATH.
-rw-r--r--gnu/packages/cups.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 281c2718e8..f91ccf5179 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages fonts) ; font-dejavu
#:use-module (gnu packages fontutils)
@@ -127,17 +128,18 @@
#t)))
(add-after 'install 'wrap-filters
(lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Some filters expect to find 'gs' in $PATH. We cannot
- ;; just hard-code its absolute file name in the source
+ ;; Some filters expect to find things in $PATH. We cannot
+ ;; just hard-code all absolute file names in the source
;; because foomatic-rip, for example, has tests like
;; 'startswith(cmd, "gs")'.
(let ((out (assoc-ref outputs "out"))
- (ghostscript (assoc-ref inputs "ghostscript")))
+ (ghostscript (assoc-ref inputs "ghostscript"))
+ (grep (assoc-ref inputs "grep")))
(for-each (lambda (file)
(wrap-program file
`("PATH" ":" prefix
- (,(string-append ghostscript
- "/bin")))))
+ (,(string-append ghostscript "/bin:"
+ grep "/bin")))))
(find-files (string-append
out "/lib/cups/filter")))
#t))))))
@@ -150,6 +152,7 @@
("freetype" ,freetype)
("font-dejavu" ,font-dejavu) ; also needed by test suite
("ghostscript" ,ghostscript/cups)
+ ("grep" ,grep)
("ijs" ,ijs)
("dbus" ,dbus)
("lcms" ,lcms)