summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Pelz <pelzflorian@pelzflorian.de>2020-10-03 00:29:56 +0200
committerFlorian Pelz <pelzflorian@pelzflorian.de>2020-10-03 10:36:31 +0000
commit0585a0d0d1fe6e334d36e2d851b42b47d6769546 (patch)
treef26602291e215cfba97b7245a78682edc183e1f4
parentc9cfcd5159f4a67ca38ccdef5398c0a601f167be (diff)
gnu: glib: Adhere to '--without-tests' option.
* gnu/packages/glib.scm (glib)[arguments]<#:phases>[configure]: Only run tests if 'tests?' is true.
-rw-r--r--gnu/packages/glib.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ca037d3b24..c703894155 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -325,11 +326,14 @@ shared NFS home directories.")
(for-each (lambda (x) (apply disable x)) failing-tests)
#t)))
(replace 'check
- (lambda _
- (setenv "MESON_TESTTHREADS"
- (number->string (parallel-job-count)))
- ;; Do not run tests marked as "flaky".
- (invoke "meson" "test" "--no-suite" "flaky")))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (begin
+ (setenv "MESON_TESTTHREADS"
+ (number->string (parallel-job-count)))
+ ;; Do not run tests marked as "flaky".
+ (invoke "meson" "test" "--no-suite" "flaky"))
+ #t)))
;; TODO: meson does not permit the bindir to be outside of prefix.
;; See https://github.com/mesonbuild/meson/issues/2561
;; We can remove this once meson is patched.