summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 12:45:35 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-10-04 00:13:32 +0200
commit5335b1593429a64ce12fb8d4b423cc6959d02186 (patch)
treefff1a39b9025c9010dcd3866ee678b4219b267a5
parentd14e3fa89c860508c041f1e5149994ff50f4afc6 (diff)
gnu: rhash: Explicity declare the _FILE_OFFSET_BITS we want.
* gnu/packages/crypto.scm (rhash)[arguments]<#:phases>[configure]: Explicity declare the _FILE_OFFSET_BITS we want.
-rw-r--r--gnu/packages/crypto.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 028c140185..c4be604ff4 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -854,7 +854,9 @@ BLAKE.")
;; ./configure is not GNU autotools' and doesn't gracefully handle
;; unrecognized options, so we must call it manually.
(lambda* (#:key configure-flags #:allow-other-keys)
- (apply invoke "./configure" configure-flags)))
+ (apply invoke "./configure"
+ (string-append "--extra-cflags=" (getenv "CFLAGS"))
+ configure-flags)))
(add-before 'check 'patch-/bin/sh
(lambda _
(substitute* "Makefile"