summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-10-03 12:23:56 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-10-04 00:13:57 +0200
commit83ecbae3123cbe8fd3cb6e0d8f72f9a152b902b4 (patch)
treead1669559a1337024f8d69a5e32ac740044213e3
parent5335b1593429a64ce12fb8d4b423cc6959d02186 (diff)
gnu: boost: Explicity declare the _FILE_OFFSET_BITS we want.
* gnu/packages/boost.scm (boost)[arguments]<#:phases>[build]: Add cflags, cxxflags.
-rw-r--r--gnu/packages/boost.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d6bdefcf83..3d620e2e26 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -148,6 +148,8 @@
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "./b2"
(format #f "-j~a" (parallel-job-count))
+ (string-append "cflags=" (getenv "CFLAGS"))
+ (string-append "cxxflags=" (getenv "CXXFLAGS"))
make-flags)))
(replace 'install
(lambda* (#:key make-flags #:allow-other-keys)