summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-05 12:12:54 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-06 16:00:41 +0200
commit03239548b8b69c866a7a22b06cc15b8e14684614 (patch)
tree036ab5b57c6ae90d1452bf6c80ff9fc49ad95c31
parentb4d6e378ba5a23c7ddef7c1b992a4765761db08b (diff)
gnu: Add python-hyperframe.
* gnu/packages/python-web.scm (python-hyperframe): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0bdea1b86d..a9f63bcf28 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2020 Holger Peters <holger.peters@posteo.de>
;;; Copyright © 2020 Noisytoot <noisytoot@gmail.com>
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -464,6 +465,34 @@ follow links and submit forms. It doesn’t do JavaScript.")
(define-public python2-mechanicalsoup
(package-with-python2 python-mechanicalsoup))
+(define-public python-hyperframe
+ (package
+ (name "python-hyperframe")
+ (version "5.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hyperframe" version))
+ (sha256
+ (base32 "07xlf44l1cw0ghxx46sbmkgzil8vqv8kxwy42ywikiy35izw3xd9"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "test"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/python-hyper/hyperframe")
+ (synopsis "HTTP/2 framing layer for Python")
+ (description
+ "This library contains the HTTP/2 framing code used in the hyper project.
+It provides a pure-Python codebase that is capable of decoding a binary stream
+into HTTP/2 frames.")
+ (license license:expat)))
+
(define-public python-sockjs-tornado
(package
(name "python-sockjs-tornado")