summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolò Balzarotti <anothersms@gmail.com>2020-05-17 14:46:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 17:08:24 +0200
commit074cd595bbcd343f86aad09794d8781846ff1927 (patch)
tree76b61324756be6ae9259616fc88a4799144f85d3
parentad14938327b745f0dd7a7c58f5ae26f419379b2f (diff)
gnu: lm-sensors: Patch references to ‘egrep’.
* gnu/packages/linux.scm (lm-sensors)[arguments]: Patch unqualified references to ‘egrep’ as well as ‘grep’. Co-authored-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aa52068794..750111f4e1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3541,9 +3541,9 @@ country-specific regulations for the wireless spectrum.")
(("cat ")
(string-append (assoc-ref inputs "coreutils")
"/bin/cat "))
- (("grep ")
+ (("e?grep " match)
(string-append (assoc-ref inputs "grep")
- "/bin/grep "))
+ "/bin/" match))
(("sed -e")
(string-append (assoc-ref inputs "sed")
"/bin/sed -e"))