summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-05 12:33:17 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-06 16:16:28 +0200
commit509bd7a75fd75549c5c685f4d7d41a78eddb003e (patch)
treeb0c78da0edcbca312e8760244b008f7f2e9c5caa
parentce3ce4f7cd78ec8cc574692f69f8b56396539a77 (diff)
gnu: Add python-sniffio.
* gnu/packages/python-xyz.scm (python-sniffio): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0128e27b8a..9e2296457d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8696,6 +8696,35 @@ designed to efficiently cope with extremely large amounts of data.")
(define-public python2-tables
(package-with-python2 python-tables))
+(define-public python-sniffio
+ (package
+ (name "python-sniffio")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sniffio" version))
+ (sha256
+ (base32 "08bsp2pp2dxzn9yzcafwzw8jlm0jf50as0ix8vfhxzk91w810f4f"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-curio" ,python-curio)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://github.com/python-trio/sniffio")
+ (synopsis "Detect which async library a program is running under")
+ (description "This package detects which async library a program is
+running under. It supports multiple async I/O packages, like Trio, and
+asyncio.")
+ ;; Either license applies.
+ (license (list license:expat license:asl2.0))))
+
(define-public python-pytest-black
(package
(name "python-pytest-black")