summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-05 12:33:15 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-06 16:05:14 +0200
commit647bbd9e9a95b2d4c1ef3d833c4329ebf6141861 (patch)
treee87d010f10972e8a99d98f718676993b312b6993
parentf8380178d55afceb7a4b7232fee1281111f6c5ce (diff)
gnu: Add python-immutables.
* gnu/packages/python-xyz.scm (python-immutables): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 48e612acd1..a86056e034 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8551,6 +8551,25 @@ Unicode-aware. It is not intended as an end-user tool.")
(define-public python2-xlrd
(package-with-python2 python-xlrd))
+(define-public python-immutables
+ (package
+ (name "python-immutables")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "immutables" version))
+ (sha256
+ (base32 "0y0aqw29g525frdnmv9paljzacpp4s21sadfbca5b137iciwr8d0"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/MagicStack/immutables")
+ (synopsis "High-performance immutable mapping type for Python")
+ (description
+ "An immutable mapping type for Python. The underlying datastructure is a
+Hash Array Mapped Trie (HAMT) used in Clojure, Scala, Haskell, and other
+functional languages.")
+ (license license:asl2.0)))
+
(define-public python-prettytable
(package
(name "python-prettytable")