summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-07 11:04:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-07 11:04:55 +0200
commitc10fb9fda446b41c85d16d16d7190491fa2a6f1a (patch)
tree2684a31beb678b54fb972cb6490579ba2abf7444
parentd8fcde01b43e94d692e50cb34c37f83100c7ab64 (diff)
gnu: parlatype: Update to 2.1.
* gnu/packages/gnome.scm (parlatype): Update to 2.1.
-rw-r--r--gnu/packages/gnome.scm102
1 files changed, 49 insertions, 53 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8f0153f6bf..ed50d30942 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10352,61 +10352,57 @@ provided there is a DBus service present:
(license license:gpl2)))
(define-public parlatype
- ;; This is one commit away from 2.0, because the latter introduced
- ;; a regression in ASR.
- (let ((commit "7d22ead13ef7578f99d24146663cc1bdb7d8c2a9")
- (revision "0"))
- (package
- (name "parlatype")
- (version (git-version "2.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gkarsay/parlatype")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0r3k3qczbzi7bs5s1rddhpsnadyr805df40bqkx0srlxgh5mfghf"))))
- (build-system meson-build-system)
- (arguments
- `(#:glib-or-gtk? #t
- #:tests? #f ;require internet access
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-parlatype
- ;; Add gstreamer plugin provided in this package to system's
- ;; plugins.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (gst-plugin-path (string-append
- out "/lib/gstreamer-1.0/"
- ":"
- (getenv "GST_PLUGIN_SYSTEM_PATH"))))
- (wrap-program (string-append out "/bin/parlatype")
- `("GST_PLUGIN_SYSTEM_PATH" ":" = (,gst-plugin-path))))
- #t)))))
- (native-inputs
- `(("appstream-glib" ,appstream-glib)
- ("desktop-file-utils" ,desktop-file-utils) ;for desktop-file-validate
- ("gettext" ,gettext-minimal)
- ("glib" ,glib "bin") ;for glib-compile-resources
- ("pkg-config" ,pkg-config)
- ("yelp-tools" ,yelp-tools)))
- (inputs
- `(("gst-plugins-base" ,gst-plugins-base)
- ("gst-plugins-good" ,gst-plugins-good)
- ("gstreamer" ,gstreamer)
- ("gtk+" ,gtk+)
- ("pocketsphinx" ,pocketsphinx)
- ("pulseaudio" ,pulseaudio)
- ("sphinxbase" ,sphinxbase)))
- (home-page "http://gkarsay.github.io/parlatype/")
- (synopsis "GNOME audio player for transcription")
- (description "Parlatype is an audio player for the GNOME desktop
+ (package
+ (name "parlatype")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gkarsay/parlatype.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c15ja0rwz3jj8bnqdq0nmqka39iwrhy8krdv2a2x8nl4shfpmv0"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:tests? #f ;require internet access
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-parlatype
+ ;; Add gstreamer plugin provided in this package to system's
+ ;; plugins.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (string-append
+ out "/lib/gstreamer-1.0/"
+ ":"
+ (getenv "GST_PLUGIN_SYSTEM_PATH"))))
+ (wrap-program (string-append out "/bin/parlatype")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" = (,gst-plugin-path))))
+ #t)))))
+ (native-inputs
+ `(("appstream-glib" ,appstream-glib)
+ ("desktop-file-utils" ,desktop-file-utils) ;for desktop-file-validate
+ ("gettext" ,gettext-minimal)
+ ("glib" ,glib "bin") ;for glib-compile-resources
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("gstreamer" ,gstreamer)
+ ("gtk+" ,gtk+)
+ ("pocketsphinx" ,pocketsphinx)
+ ("pulseaudio" ,pulseaudio)
+ ("sphinxbase" ,sphinxbase)))
+ (home-page "http://gkarsay.github.io/parlatype/")
+ (synopsis "GNOME audio player for transcription")
+ (description "Parlatype is an audio player for the GNOME desktop
environment. Its main purpose is the manual transcription of spoken
audio files.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public jsonrpc-glib
(package