summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-06 22:58:52 -0400
committerMark H Weaver <mhw@netris.org>2015-07-06 23:01:56 -0400
commitc803ffcb3a9d5669bf5bae62b66fa058d697545c (patch)
treec2a375fb29f081c5c3f197edb77b7529a7f46cc7
parent0ba652b2f58bcc9fee16228721c77d3676b17302 (diff)
gnu: icecat: Fix build against libvpx 1.4.
* gnu/packages/patches/icecat-libvpx-1.4.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/gnuzilla.scm3
-rw-r--r--gnu/packages/patches/icecat-libvpx-1.4.patch30
3 files changed, 33 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index d6b2aad7c1..71c238b564 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -481,6 +481,7 @@ dist_patch_DATA = \
gnu/packages/patches/icecat-CVE-2015-2739.patch \
gnu/packages/patches/icecat-CVE-2015-2740.patch \
gnu/packages/patches/icecat-CVE-2015-2743.patch \
+ gnu/packages/patches/icecat-libvpx-1.4.patch \
gnu/packages/patches/irrlicht-mesa-10.patch \
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
gnu/packages/patches/kmod-module-directory.patch \
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 61a89a41c2..d84275e78d 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -293,7 +293,8 @@ standards.")
"icecat-CVE-2015-2724-pt4.patch"
"icecat-CVE-2015-2733-pt2.patch"
"icecat-CVE-2015-2738.patch"
- "icecat-CVE-2015-2740.patch")))))
+ "icecat-CVE-2015-2740.patch"
+ "icecat-libvpx-1.4.patch")))))
(build-system gnu-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
diff --git a/gnu/packages/patches/icecat-libvpx-1.4.patch b/gnu/packages/patches/icecat-libvpx-1.4.patch
new file mode 100644
index 0000000000..e6e5fb3213
--- /dev/null
+++ b/gnu/packages/patches/icecat-libvpx-1.4.patch
@@ -0,0 +1,30 @@
+The libvpx package 1.4.0 brings new names for various constants.
+To build against the libvpx some few constants have to be renamed.
+
+Patch by Carsten Schoenert <c.schoenert@t-online.de>.
+Copied from Debian.
+
+--- a/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
++++ b/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
+@@ -180,7 +180,7 @@ int VP8EncoderImpl::InitEncode(const VideoCodec* inst,
+ // Creating a wrapper to the image - setting image data to NULL. Actual
+ // pointer will be set in encode. Setting align to 1, as it is meaningless
+ // (actual memory is not allocated).
+- raw_ = vpx_img_wrap(NULL, IMG_FMT_I420, codec_.width, codec_.height,
++ raw_ = vpx_img_wrap(NULL, VPX_IMG_FMT_I420, codec_.width, codec_.height,
+ 1, NULL);
+ // populate encoder configuration with default values
+ if (vpx_codec_enc_config_default(vpx_codec_vp8_cx(), config_, 0)) {
+@@ -349,9 +349,9 @@ int VP8EncoderImpl::Encode(const I420VideoFrame& input_image,
+ }
+ // Image in vpx_image_t format.
+ // Input image is const. VP8's raw image is not defined as const.
+- raw_->planes[PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
+- raw_->planes[PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
+- raw_->planes[PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
++ raw_->planes[VPX_PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
++ raw_->planes[VPX_PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
++ raw_->planes[VPX_PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
+ // TODO(mikhal): Stride should be set in initialization.
+ raw_->stride[VPX_PLANE_Y] = input_image.stride(kYPlane);
+ raw_->stride[VPX_PLANE_U] = input_image.stride(kUPlane);