summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-05 12:33:16 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-06 16:06:08 +0200
commitce3ce4f7cd78ec8cc574692f69f8b56396539a77 (patch)
treeabd0c3cc30cc6ca11a6296f1af3dfd2dc1a6a1c5
parent647bbd9e9a95b2d4c1ef3d833c4329ebf6141861 (diff)
gnu: Add python-curio.
* gnu/packages/python-xyz.scm (python-curio): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a86056e034..0128e27b8a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8594,6 +8594,36 @@ printing of sub-tables by specifying a row range.")
(define-public python2-prettytable
(package-with-python2 python-prettytable))
+(define-public python-curio
+ (package
+ (name "python-curio")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "curio" version))
+ (sha256
+ (base32 "16wkww6kh511b9bzsfhpvrv0766cc6ssgbzz4lgpjnrzzgx21wwh"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "-k"
+ ;; Tries to open an outgoing connection.
+ "not test_ssl_outgoing"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/dabeaz/curio")
+ (synopsis "Coroutine-based library for concurrent Python")
+ (description
+ "Curio is a coroutine-based library for concurrent Python systems
+programming. It provides standard programming abstractions such as as
+tasks, sockets, files, locks, and queues.")
+ (license license:bsd-3)))
+
(define-public python-tables
(package
(name "python-tables")