summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-04-07 18:34:47 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-07 18:34:47 +0200
commit6b6fb78724869c03394d0e6dc2f50f0777f6d467 (patch)
tree57f37725fcb60db5815df92e5dc3bdf3cd1692ef
parentedb9a5b835fb0283bc92219573b5b55d057cd76b (diff)
gnu: glibc: Build with '--strip-debug' instead of '--strip-all'.
Fixes <https://issues.guix.gnu.org/54728>. Reported by Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>. * gnu/packages/base.scm (glibc)[arguments]: Add #:strip-flags.
-rw-r--r--gnu/packages/base.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f4f6fce6e0..72329dbaf6 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016, 2018 Mark H Weaver <mhw@netris.org>
@@ -742,6 +742,10 @@ the store.")
(guix build utils)
(guix build gnu-build-system))
+ ;; Strip binaries but preserve the symbol table needed by Valgrind:
+ ;; <https://lists.gnu.org/archive/html/help-guix/2022-03/msg00036.html>.
+ #:strip-flags '("--strip-debug")
+
#:configure-flags
(list "--sysconfdir=/etc"