summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-02-03 17:54:31 +0000
committerLudovic Courtès <ludo@gnu.org>2022-03-28 09:23:41 +0200
commita59afdc92e8d29edf2cb2193f967715e46c885c7 (patch)
treebd5c97b78795bb7414f33e2afc867deda7c1bef9
parentc6b5161e97ed1010d61331874b09c3231af3b1f9 (diff)
gnu: boost: Update to 1.78.0.
* gnu/packages/boost.scm (boost): Update to 1.78.0. [source](patches): Add upstream patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/boost.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index b53b1f4257..2373dd9feb 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -15,9 +15,8 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
-;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
@@ -68,15 +67,21 @@
(define-public boost
(package
(name "boost")
- (version "1.77.0")
+ (version "1.78.0")
(source (origin
(method url-fetch)
(uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
version "/source/boost_"
(version-with-underscores version) ".tar.bz2"))
+ (patches
+ (list (boost-patch
+ ;; 1.78.0 was released with a faulty installation routine:
+ ;; <https://github.com/bfgroup/b2/pull/113>.
+ "0001-b2-fix-install.patch" version
+ "02ljm22a4gcaj10xng8ww8aifrrlzm1pgyp08c06fd75f9pbkrbi")))
(sha256
(base32
- "0m08hhk3l7zvzajyk39qlw566q3fhixayhc2j11328qf0gy8b7zw"))))
+ "1k5w6l3xsa9vipwk14sjb1vhsj88xwz7jr964996rcmxsisz30c6"))))
(build-system gnu-build-system)
(inputs (list icu4c zlib))
(native-inputs