summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-12-13 14:59:35 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-05-12 19:27:59 +0200
commita68d1d47eedb277aab67ee98e79c1d08ef501612 (patch)
tree4ce664f52a1e25bc3a7205d3292771095aadbef5
parentd79c103e1146e4fa2cd78b44c3d4c3c7f8455444 (diff)
gnu: commencement: tcc-boot0: Update to 0.9.26-1136-g0fbeb2dd.
* gnu/packages/commencement.scm (tcc-boot0)[source]: Update to 0.9.26-1136-g0fbeb2dd. [native-inputs]: Add stage0-posix and mes-boot, remove %bootstrap-mescc-tools and %bootstrap-mes-rewired.
-rw-r--r--gnu/packages/commencement.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 776f5955a2..d01b0ef8c9 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -615,7 +615,7 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
(define tcc-boot0
- ;; Pristine tcc cannot be built by MesCC, we are keeping a delta of 11
+ ;; Pristine tcc cannot be built by MesCC, we are keeping a delta of 30
;; patches. In a very early and rough form they were presented to the
;; TinyCC developers, who at the time showed no interest in supporting the
;; bootstrappable effort; we will try again later. These patches have been
@@ -624,28 +624,27 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
(package
(inherit tcc)
(name "tcc-boot0")
- (version "0.9.26-1103-g6e62e0e")
+ (version "0.9.26-1136-g5bba73cc")
(source (origin
(method url-fetch)
(uri (list
(string-append "mirror://gnu/guix/mirror/"
"tcc-" version ".tar.gz")
- (string-append
- "https://lilypond.org/janneke/mes/20191117/"
- "/tcc-" version ".tar.gz")))
+ (string-append "https://lilypond.org/janneke/tcc/"
+ "tcc-" version ".tar.gz")))
(sha256
(base32
- "1qbybw7mxbgkv3sazvz1v7c8byq998vk8f1h25ik8w3d2l63lxng"))))
+ "1y2f04qwdqg7dgxiscbf0ibybx2gclniwbbcsxpayazzii2cvji3"))))
(build-system gnu-build-system)
(supported-systems '("i686-linux" "x86_64-linux"))
(inputs '())
(propagated-inputs '())
(native-inputs
`(("mes" ,mes-boot)
+ ("mescc-tools" ,stage0-posix)
("nyacc-source" ,(bootstrap-origin
(origin (inherit (package-source nyacc-1.00.2))
(snippet #f))))
- ("mescc-tools" ,%bootstrap-mescc-tools)
,@(%boot-gash-inputs)))
(arguments
`(#:implicit-inputs? #f
@@ -660,18 +659,17 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
(with-directory-excursion ".."
(invoke "tar" "-xvf" nyacc-source)))))
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref %outputs "out"))
(dir (with-directory-excursion ".." (getcwd)))
- (interpreter "/lib/mes-loader"))
-
- (setenv "prefix" out)
- (setenv "GUILE_LOAD_PATH"
- (string-append dir "/nyacc-0.99.0/module"))
-
+ (interpreter "/lib/mes-loader")
+ (mes (assoc-ref inputs "mes"))
+ (mescc (string-append mes "/bin/mescc")))
(substitute* "conftest.c"
(("volatile") ""))
-
+ (setenv "prefix" out)
+ (setenv "GUILE_LOAD_PATH"
+ (string-append dir "/nyacc-1.00.2/module"))
(invoke "sh" "configure"
"--cc=mescc"
(string-append "--prefix=" out)
@@ -681,7 +679,7 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
(replace 'build
(lambda _
(substitute* "bootstrap.sh" ; Show some progress
- (("^( *)((cp|ls|mkdir|rm|[.]/tcc|[.]/[$][{PROGRAM_PREFIX[}]tcc) [^\"]*[^\\])\n" all space cmd)
+ (("^( *)((cp|ls|mkdir|rm|[.]/tcc|[.]/[$][{program_prefix[}]tcc) [^\"]*[^\\])\n" all space cmd)
(string-append space "echo \"" cmd "\"\n"
space cmd "\n")))
(invoke "sh" "bootstrap.sh")))
@@ -901,8 +899,8 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
(string-append out "/include"))
(copy-recursively (string-append tcc "/lib")
(string-append out "/lib"))
- (invoke "tcc" "-D" "TCC_TARGET_I386=1" "-c" "-o" "libtcc1.o" "lib/libtcc1.c")
- (invoke "tcc" "-ar" "rc" "libtcc1.a" "libtcc1.o")
+ (invoke "./tcc" "-D" "TCC_TARGET_I386=1" "-c" "-o" "libtcc1.o" "lib/libtcc1.c")
+ (invoke "./tcc" "-ar" "rc" "libtcc1.a" "libtcc1.o")
(copy-file "libtcc1.a" (string-append out "/lib/libtcc1.a"))
(delete-file (string-append out "/lib/tcc/libtcc1.a"))
(copy-file "libtcc1.a"