summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-10 21:49:38 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-10 22:15:26 +0100
commit082be6d2a1fe62aba51a119a28a774eeb99f23bd (patch)
tree32c06b3110c82b6b70b74e446ccffa29890e26f6
parent74d212911e6de68cdea0d2d88fcf63ca3a193846 (diff)
gnu: e2fsprogs: Remove timestamp from 'libext2fs.info.gz'.
* gnu/packages/linux.scm (e2fsprogs)[source](snippet): Patch 'doc/Makefile.in' to use the '-n' option of gzip.
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b7cbba4d10..70dbf816dc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -622,9 +622,15 @@ slabtop, and skill.")
"1ix0b83zgw5n0p2grh2961c6796m92yr2jqc2sbr23x3lfsp8r71"))
(modules '((guix build utils)))
(snippet
- '(substitute* "MCONFIG.in"
- (("INSTALL_SYMLINK = /bin/sh")
- "INSTALL_SYMLINK = sh")))))
+ '(begin
+ (substitute* "MCONFIG.in"
+ (("INSTALL_SYMLINK = /bin/sh")
+ "INSTALL_SYMLINK = sh"))
+
+ ;; Do not include a timestamp in libext2fs.info.gz.
+ (substitute* "doc/Makefile.in"
+ (("gzip -9")
+ "gzip -9n"))))))
(build-system gnu-build-system)
(inputs `(("util-linux" ,util-linux)))
(native-inputs `(("pkg-config" ,pkg-config)