summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-12 21:14:38 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-12 21:14:38 +0100
commit26b307e2cc96147efd80b379a7d1b27e764f5c31 (patch)
treecd8746bb4c628e07876b3e14a6285c4cba914dd9
parentbd3fa66676eb43c65690f57d779708ad6afb4e5b (diff)
gnu: Add python-lxml.
* gnu/packages/python.scm (python-lxml, python2-lxml): New variables.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2ba359a7f2..158c1ac1f9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages which)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
@@ -2985,3 +2986,33 @@ translate the complete SQLite API into Python.")
(define-public python2-apsw
(package-with-python2 python-apsw))
+
+(define-public python-lxml
+ (package
+ (name "python-lxml")
+ (version "3.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/l/lxml/lxml-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0pd23qz8vms1mgm41p96h4vac5y91igs4wr9640gnvxgk019kmf7"))))
+ (build-system python-build-system)
+ (inputs
+ `(("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "http://lxml.de/")
+ (synopsis
+ "Python XML processing library")
+ (description
+ "The lxml XML toolkit is a Pythonic binding for the C libraries
+libxml2 and libxslt.")
+ (license bsd-3))) ; and a few more, see LICENSES.txt
+
+(define-public python2-lxml
+ (package-with-python2 python-lxml))