summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2017-01-09 01:31:13 +0100
committerDavid Craven <david@craven.ch>2017-01-10 11:58:11 +0100
commit313880c73ade2e907e9c51cf355f8a56c5cdeaaa (patch)
tree14e109d9c4b332723af07ef82939bbf6c954d774
parentf03168327f7f249dde73fb1014d460a4b99ee40f (diff)
gnu: e2fsck/static: Only copy e2fsck.
* gnu/packages/linux.scm (e2fsck/static)[arguments]: Only copy e2fsck. [synopsis, description]: Adjust accordingly.
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d018efdcb9..6b5523165a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -705,6 +705,8 @@ slabtop, and skill.")
(version (package-version e2fsprogs))
(build-system trivial-build-system)
(source #f)
+ (inputs
+ `(("e2fsprogs" ,e2fsprogs/static)))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -713,23 +715,18 @@ slabtop, and skill.")
(ice-9 ftw)
(srfi srfi-26))
- (let ((source (string-append (assoc-ref %build-inputs "e2fsprogs")
- "/sbin"))
+ (let ((e2fsck (string-append (assoc-ref %build-inputs "e2fsprogs")
+ "/sbin/e2fsck"))
(bin (string-append (assoc-ref %outputs "out") "/sbin")))
(mkdir-p bin)
(with-directory-excursion bin
- (for-each (lambda (file)
- (copy-file (string-append source "/" file)
- file)
- (remove-store-references file)
- (chmod file #o555))
- (scandir source (cut string-prefix? "fsck." <>))))))))
- (inputs `(("e2fsprogs" ,e2fsprogs/static)))
- (synopsis "Statically-linked fsck.* commands from e2fsprogs")
- (description
- "This package provides statically-linked command of fsck.ext[234] taken
-from the e2fsprogs package. It is meant to be used in initrds.")
+ (copy-file e2fsck "e2fsck")
+ (remove-store-references "e2fsck")
+ (chmod "e2fsck" #o555))))))
(home-page (package-home-page e2fsprogs))
+ (synopsis "Statically-linked e2fsck command from e2fsprogs")
+ (description "This package provides statically-linked e2fsck command taken
+from the e2fsprogs package. It is meant to be used in initrds.")
(license (package-license e2fsprogs))))
(define-public extundelete