summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-09-11 12:39:58 -0400
committerLeo Famulari <leo@famulari.name>2016-09-11 13:04:00 -0400
commit35eade9cf3b1f50818d061c64deb628ee60918fc (patch)
tree2ce1e4ad0064b2c0b73f105d1f5fe22f04306595
parentcbe2cc02fb0fe8a6291e2a1e66257d3c477678ff (diff)
gnu: jbig2dec: Update to 0.13.
* gnu/packages/image.scm (jbig2dec): Update to 0.13. [source]: Update URL. [home-page]: Update URL. * gnu/packages/patches/jbig2dec-ignore-testtest.patch: Adjust patch.
-rw-r--r--gnu/packages/image.scm11
-rw-r--r--gnu/packages/patches/jbig2dec-ignore-testtest.patch24
2 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 47b17d49d0..d7ffa99514 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -351,15 +351,14 @@ arithmetic ops.")
(define-public jbig2dec
(package
(name "jbig2dec")
- (version "0.11")
+ (version "0.13")
(source
(origin
(method url-fetch)
- (uri ;; The link on the homepage is dead.
- (string-append "http://distfiles.gentoo.org/distfiles/" name "-"
- version ".tar.gz"))
+ (uri (string-append "http://downloads.ghostscript.com/public/" name "/"
+ name "-" version ".tar.gz"))
(sha256
- (base32 "1ffhgmf2fqzk0h4k736pp06z7q5y4x41fg844bd6a9vgncq86bby"))
+ (base32 "04akiwab8iy5iy34razcvh9mcja9wy737civ3sbjxk4j143s1b2s"))
(patches (search-patches "jbig2dec-ignore-testtest.patch"))))
(build-system gnu-build-system)
@@ -374,7 +373,7 @@ This is a decoder only implementation, and currently is in the alpha
stage, meaning it doesn't completely work yet. However, it is
maintaining parity with available encoders, so it is useful for real
work.")
- (home-page "http://jbig2dec.sourceforge.net/")
+ (home-page "http://www.ghostscript.com/jbig2dec.html")
(license license:gpl2+)))
(define-public openjpeg
diff --git a/gnu/packages/patches/jbig2dec-ignore-testtest.patch b/gnu/packages/patches/jbig2dec-ignore-testtest.patch
index 1bf8f7ad76..1efde8628c 100644
--- a/gnu/packages/patches/jbig2dec-ignore-testtest.patch
+++ b/gnu/packages/patches/jbig2dec-ignore-testtest.patch
@@ -1,14 +1,16 @@
Do not run the "testtest script", it doesn't seem to do anything and reports
failiute. TODO: Actually fix the test instead of ignoring it.
---- a/Makefile.in 2010-02-02 20:13:56.000000000 +0100
-+++ b/Makefile.in 2014-09-13 17:50:10.957816767 +0200
-@@ -181,7 +181,7 @@
-
- MAINTAINERCLEANFILES = config_types.h.in
-
--TESTS = test_sha1 test_jbig2dec.py test_huffman test_arith
-+TESTS = test_sha1 test_huffman test_arith
-
- test_sha1_SOURCES = sha1.c sha1.h
- test_sha1_CFLAGS = -DTEST
+diff --git a/Makefile.in b/Makefile.in
+index 0573592..1a5de77 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -93,7 +93,7 @@ host_triplet = @host@
+ bin_PROGRAMS = jbig2dec$(EXEEXT)
+ noinst_PROGRAMS = test_sha1$(EXEEXT) test_huffman$(EXEEXT) \
+ test_arith$(EXEEXT)
+-TESTS = test_sha1$(EXEEXT) test_jbig2dec.py test_huffman$(EXEEXT) \
++TESTS = test_sha1$(EXEEXT) test_huffman$(EXEEXT) \
+ test_arith$(EXEEXT)
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4