summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-11-02 12:47:32 +0100
committerAndreas Enge <andreas@enge.fr>2014-11-04 13:40:32 +0100
commit3c0f23290d49369a187753e5f58fd4878cdee1ca (patch)
tree766a31523e3cb1cb5580c5b0b2ee3c1a76947517
parentb38e45d81322e6253a664a1a9cd9637e9acf6d96 (diff)
gnu: python-wrapper: Propagate input python.
* gnu/packages/python.scm (python-wrapper): Propagate input python, so that the python libraries are made available as well as the python3 binaries without the symbolic links.
-rw-r--r--gnu/packages/python.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e342afd0f6..378660482f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
@@ -221,7 +221,7 @@ data types.")
(name "python-wrapper")
(source #f)
(build-system trivial-build-system)
- (inputs `(("python" ,python)))
+ (propagated-inputs `(("python" ,python)))
(arguments
`(#:modules ((guix build utils))
#:builder