summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-25 15:34:58 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-14 14:06:29 +0100
commit53239b5f9649b5b27945eafd550c6b296b4140d1 (patch)
tree3ed9c1ac7e59eea91c500ef2faae0d0359b0f341
parent6e376ca46ac6e97bfe6b5db7f54f717edf3cecb6 (diff)
gnu: Add ruby-utils.
* gnu/packages/ruby.scm (ruby-utils): New variable.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0e4d1aaf64..2f3e9f3a09 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2043,6 +2043,33 @@ process tree data structure for the current host.")
;; There is no mention of the "or later" clause.
(license license:gpl2)))
+(define-public ruby-utils
+ (package
+ (name "ruby-utils")
+ (version "0.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "utils" version))
+ (sha256
+ (base32
+ "0vycgscxf3s1xn4yyfsq54zlh082581ga8azybmqgc4pij6iz2cd"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-tins" ,ruby-tins)
+ ("ruby-term-ansicolor" ,ruby-term-ansicolor)
+ ("ruby-pstree" ,ruby-pstree)
+ ("ruby-pry-editline" ,ruby-pry-editline)))
+ (native-inputs
+ `(("ruby-gem-hadar" ,ruby-gem-hadar)
+ ("bundler" ,bundler)))
+ (synopsis "Command line tools for working with Ruby")
+ (description
+ "This package provides assorted command line tools that may be useful
+when working with Ruby code.")
+ (home-page "https://github.com/flori/utils")
+ ;; There is no mention of the "or later" clause.
+ (license license:gpl2)))
+
(define-public ruby-json
(package
(name "ruby-json")