summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-23 17:58:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-12-10 20:24:11 +0200
commit5d69165797cd96bb0a04b1b049b0ce4c0673f439 (patch)
treed527be4cd60205cd34ab6bce258d991968b735fa
parentaddc808ddc4a97bb55b13a82e580664429175910 (diff)
gnu: python-requests: Update to 2.8.1.
* gnu/packages/python.scm (python-requests): Update to 2.8.1. [native-inputs]: Move python-setuptools here. [inputs]: Remove python-certifi. [propagated-inputs]: Add python-py, python-pytest, python-pytest-cov, python-wheel. [arguments]: Enable tests.
-rw-r--r--gnu/packages/python.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6a7fbf8524..647dbd4fed 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2194,21 +2194,21 @@ compatible install in a way that is very close to the on-disk format.")
(define-public python-requests
(package
(name "python-requests")
- (version "2.8.0")
+ (version "2.8.1")
(source (origin
(method url-fetch)
- (uri
- (string-append
- "https://pypi.python.org/packages/source/r/requests/requests-"
- version ".tar.gz"))
+ (uri (pypi-uri "requests" version))
(sha256
(base32
- "0yrvj8hfnabrdxds59w6d6887sn5j0jlgpmcq04lk4k0kdc07w5j"))))
+ "0ny2nr1sqr4hcn3903ghmh7w2yni8shlfv240a8c9p6wyidqvzl4"))))
(build-system python-build-system)
- (inputs
- `(("python-setuptools" ,python-setuptools)
- ("python-certifi" ,python-certifi)))
- (arguments `(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (propagated-inputs
+ `(("python-py" ,python-py)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-wheel" ,python-wheel)))
(home-page "http://python-requests.org/")
(synopsis "Python HTTP library")
(description