summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-04-25 11:17:21 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-26 16:41:15 +0200
commit6b49a37e6b653797e3335198203dec884798d037 (patch)
tree6944cace4cb73f58ece43d043d7d6740c87fb60b
parent547cb17dafff07a8438f0155e5608f5178a8605a (diff)
gnu: Add filevercmp.
* gnu/packages/bioinformatics.scm (filevercmp): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 899ce1ca0c..e973fff409 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5074,3 +5074,31 @@ negative binomial distribution to model the read counts among the samples in
the same group, and look for consistent differences between ChIP and control
group or two ChIP groups run under different conditions.")
(license license:gpl3+)))
+
+(define-public filevercmp
+ (let ((commit "1a9b779b93d0b244040274794d402106907b71b7"))
+ (package
+ (name "filevercmp")
+ (version (string-append "0-1." (string-take commit 7)))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ekg/filevercmp/archive/"
+ commit ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0yp5jswf5j2pqc6517x277s4s6h1ss99v57kxw9gy0jkfl3yh450"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests to run.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "filevercmp" bin)))))))
+ (home-page "https://github.com/ekg/filevercmp")
+ (synopsis "This program compares version strings")
+ (description "This program compares version strings. It intends to be a
+replacement for strverscmp.")
+ (license license:gpl3+))))