summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-01-04 16:21:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-01-05 18:47:40 +0100
commit6c8a387af2e08c8d3bb7fa558e6c3bbdb28681ac (patch)
treeb5923409c1e915953a7d15a5c062562f215b71aa
parent12c15242f422ab62bc0e653365c692047386b604 (diff)
gnu: Add ghc-markdown-unlit.
* gnu/packages/haskell.scm (ghc-markdown-unlit): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index de061a6300..ac0eac3fe8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8073,4 +8073,31 @@ It features a complete, well-tested parser and pretty printer for all of C99
and a large set of GNU extensions.")
(license license:bsd-3)))
+(define-public ghc-markdown-unlit
+ (package
+ (name "ghc-markdown-unlit")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/markdown-unlit/"
+ "markdown-unlit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kj2bffl7ndd8ygwwa3r1mbpwbxbfhyfgnbla8k8g9i6ffp0qrbw"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-silently" ,ghc-silently)
+ ("ghc-stringbuilder" ,ghc-stringbuilder)
+ ("ghc-temporary" ,ghc-temporary)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/sol/markdown-unlit#readme")
+ (synopsis "Literate Haskell support for Markdown")
+ (description "This package allows you to have a README.md that at the
+same time is a literate Haskell program.")
+ (license license:expat)))
+
;;; haskell.scm ends here