summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-06-18 16:16:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-20 07:06:57 +0200
commit79b3d3ea58586bb29ee71c98dcd261154572ace2 (patch)
tree49b71eceb9299895111c577bfda681dd45a6f839
parentdb1a496071bc05c0961b61a2e64fb7b25d6856fb (diff)
gnu: Add emacs-hydra.
* gnu/packages/emacs.scm (emacs-hydra): New variable.
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index bb8723b0ec..32eb844cb0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1717,6 +1717,33 @@ features found in other packages it also brings many improvements as
well as completely new features.")
(license license:gpl3+)))
+(define-public emacs-hydra
+ (package
+ (name "emacs-hydra")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/abo-abo/hydra/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19ynkjlg3jj7x90xxbz885324h6nkxmzlb2c2c95xkr20zckn0lk"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/abo-abo/hydra")
+ (synopsis "Make Emacs bindings that stick around")
+ (description
+ "This package can be used to tie related commands into a family of short
+bindings with a common prefix---a Hydra. Once you summon the Hydra (through
+the prefixed binding), all the heads can be called in succession with only a
+short extension. Any binding that isn't the Hydra's head vanquishes the
+Hydra. Note that the final binding, besides vanquishing the Hydra, will still
+serve its original purpose, calling the command assigned to it. This makes
+the Hydra very seamless; it's like a minor mode that disables itself
+automatically.")
+ (license license:gpl3+)))
+
(define-public emacs-clojure-mode
(package
(name "emacs-clojure-mode")