summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-11 13:23:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-12-11 14:18:10 +0200
commit7bcbd40dc8efcd706beb62a4aa9342359c9d9438 (patch)
treed28ad95b42a5380fd6933c8eb0b2695d0452923a
parent8cabd349b4f82e31a49202cb56b0a999fc926804 (diff)
gnu: gnumeric: Update to 1.12.24.
* gnu/packages/gnome.scm (gnumeric): Update to 1.12.24. [inputs]: Add librsvg, libxslt. [arguments]: Use "modify-phases" syntax.
-rw-r--r--gnu/packages/gnome.scm31
1 files changed, 17 insertions, 14 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9bb51e5609..bf9c45be34 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1515,7 +1515,7 @@ Hints specification (EWMH).")
(define-public gnumeric
(package
(name "gnumeric")
- (version "1.12.17")
+ (version "1.12.24")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1523,31 +1523,34 @@ Hints specification (EWMH).")
name "-" version ".tar.xz"))
(sha256
(base32
- "18bvc3phghr4p5440fp8hm6gvp53d3mqs9cyc637zpmk0b6bcp7c"))))
+ "0lcm8k0jb8rd5y4ii803f21nv8rx6gc3mmdlrj5h0rkkn9qm57f5"))))
(build-system gnu-build-system)
(arguments
`(;; The gnumeric developers don't worry much about failing tests.
;; See https://bugzilla.gnome.org/show_bug.cgi?id=732387
#:tests? #f
#:phases
- (alist-cons-before
- 'configure 'pre-conf
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make install tries to write into the directory of goffice
- ;; I am informed that this only affects the possibility to embed a
- ;; spreadsheet inside an Abiword document. So presumably when we
- ;; package Abiword we'll have to refer it to this directory.
- (substitute* "configure"
- (("^GOFFICE_PLUGINS_DIR=.*")
- (string-append "GOFFICE_PLUGINS_DIR="
- (assoc-ref outputs "out") "/goffice/plugins"))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'pre-conf
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make install tries to write into the directory of goffice
+ ;; I am informed that this only affects the possibility to embed a
+ ;; spreadsheet inside an Abiword document. So presumably when we
+ ;; package Abiword we'll have to refer it to this directory.
+ (substitute* "configure"
+ (("^GOFFICE_PLUGINS_DIR=.*")
+ (string-append "GOFFICE_PLUGINS_DIR="
+ (assoc-ref outputs "out")
+ "/goffice/plugins"))))))))
(inputs
`(("glib" ,glib)
("gtk+" ,gtk+)
("goffice" ,goffice)
("libgsf" ,libgsf)
+ ("librsvg" ,librsvg)
("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
("zlib" ,zlib)))
(native-inputs
`(("intltool" ,intltool)