summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-09-19 13:16:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-09-23 08:14:33 +0200
commitcaf9055c136624e42351b1bf1259160c0f11973e (patch)
tree00cbb795165d7e1a37449ab3fc242ab38a7e11df
parent430505eba33b7bb59fa2d22e0f21ff317cbc320d (diff)
gnu: Add XJackFreak.
* gnu/packages/audio.scm (xjackfreak): New variable.
-rw-r--r--gnu/packages/audio.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 029f40c37d..2511f121c2 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -60,6 +60,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages zip)
#:use-module (srfi srfi-1))
@@ -1739,6 +1740,39 @@ directly to a different computer on your LAN network. It is an audio daemon
with a much different focus than most other audio daemons.")
(license license:gpl3+)))
+(define-public xjackfreak
+ (package
+ (name "xjackfreak")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/johnhldavis/xjackfreak/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xj6gpxfnw9jbdgwgm0x23xgfvj2kwmwb1nk0drw8lxgcchkq7d9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "docdir=" (assoc-ref %outputs "out")
+ "/share/doc/xjackfreak"))))
+ (inputs
+ `(("jack" ,jack-1)
+ ("libx11" ,libx11)
+ ("libxt" ,libxt)
+ ("libxext" ,libxext)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/johnhldavis/xjackfreak")
+ (synopsis "JACK audio frequency analyzer and display")
+ (description
+ "XJackFreak is an audio analysis and equalizing tool for the Jack Audio
+Connection Kit. It can display the FFT of any input, modify it and output the
+result.")
+ (license license:gpl3+)))
+
(define-public zita-convolver
(package
(name "zita-convolver")