summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-06 22:14:48 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-07 00:38:03 +0100
commitd7d5050c51d6b2bb1843bbcdf60c4d19dd880020 (patch)
tree04117ffe2d793ce3038c95e5cf5d7c71cbdf63b6
parenta2bd16ff99c0350db9ed5d1ec3b3d99dd574b6d0 (diff)
gnu: ao-cad: Point 'LD_LIBRARY_PATH' to Mesa.
* gnu/packages/engineering.scm (ao)[arguments]: In 'install-guile-bindings', wrap 'ao-guile' to set 'LD_LIBRARY_PATH'. [inputs]: Add MESA.
-rw-r--r--gnu/packages/engineering.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 831e63beda..b147764a7d 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
@@ -545,7 +545,7 @@ as well as pick-place files.")
(getenv "CPLUS_INCLUDE_PATH")))
#t)))
(add-after 'install 'install-guile-bindings
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
;; Install the Guile bindings (the build system only installs
;; libao.so.)
(let* ((out (assoc-ref outputs "out"))
@@ -574,6 +574,14 @@ as well as pick-place files.")
(install-file "bin/ao-guile"
(string-append out "/bin"))
+
+ ;; Allow Ao to dlopen the relevant GL libraries. Otherwise
+ ;; it fails with:
+ ;; Couldn't find current GLX or EGL context.
+ (let ((mesa (assoc-ref inputs "mesa")))
+ (wrap-program (string-append out "/bin/ao-guile")
+ `("LD_LIBRARY_PATH" ":" prefix
+ (,(string-append mesa "/lib")))))
#t)))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -583,6 +591,7 @@ as well as pick-place files.")
("libpng" ,libpng)
("glfw" ,glfw)
("libepoxy" ,libepoxy)
+ ("mesa" ,mesa)
("eigen" ,eigen)
("glm" ,glm)
("guile" ,guile-2.0)))