summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-04 14:53:03 +0000
committerLudovic Courtès <ludo@gnu.org>2017-01-09 10:33:07 +0100
commitf048f12ba18f97a8d956f46093bf8bb5c7cc3ead (patch)
tree1ecf8044ef49292e7f9203bcb310f8c3ab2ca592
parentbb0756c7c7a963cd713a04188808c56c6290e500 (diff)
gnu: Add dotherside.
* gnu/packages/qt.scm (dotherside): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/qt.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 15beb8037e..df6fe168ad 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <ng0@libertad.pw>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
@@ -1313,3 +1313,37 @@ embed content from the World Wide Web into your Qt application. At the same
time Web content can be enhanced with native controls.")
(license license:lgpl2.1+)))
+
+(define-public dotherside
+ (package
+ (name "dotherside")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/filcuc/DOtherSide/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pqlrvy4ajjir80ra79ka3n0rjj0ir0f0m91cq86iz3nnw8w148z"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://github.com/frankosterfeld/qtkeychain")
+ (synopsis "C language library for creating bindings for the Qt QML language")
+ (description
+ "DOtherSide is a C language library for creating bindings for the
+QT QML language. The following features are implementable from
+a binding language:
+@itemize
+@item Creating custom QObject
+@item Creating custom QAbstractListModels
+@item Creating custom properties, signals and slots
+@item Creating from QML QObject defined in the binded language
+@item Creating from Singleton QML QObject defined in the binded language
+@end itemize\n")
+ (license license:lgpl3))) ;version 3 only (+ exception)