summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-06-19 19:00:09 -0400
committerKei Kebreau <kei@openmailbox.org>2016-06-20 18:49:11 -0400
commitf317aeb4380e2038f98c4cc7e8e08cf6f4ee5959 (patch)
treecb9366db8a547d2030cf259ae2577476c324a8fb
parent5c310940edc8d6b8c85c44f2d9cf258e937ab156 (diff)
gnu: Add warzone2100.
* gnu/packages/games.scm (warzone2100): New variable.
-rw-r--r--gnu/packages/games.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b0bf4e3546..4141d5eedd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2396,3 +2396,54 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
your way through an underground cave system in search of the Grue. Can you
capture it and get out alive?")
(license license:agpl3+)))
+
+(define-public warzone2100
+ (package
+ (name "warzone2100")
+ (version "3.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name
+ "/releases/" version "/" name "-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "0hm49i2knvvg3wlnryv7h4m84s3qa7jfyym5yy6365sx8wzcrai1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'set-paths 'set-sdl-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CPATH"
+ (string-append (assoc-ref inputs "sdl-union")
+ "/include/SDL"))
+ #t)))))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("unzip" ,unzip)
+ ("zip" ,zip)))
+ (inputs `(("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("fribidi" ,fribidi)
+ ("glew" ,glew)
+ ("libtheora" ,libtheora)
+ ("libvorbis" ,libvorbis)
+ ("libxrandr" ,libxrandr)
+ ("openal" ,openal)
+ ("physfs" ,physfs)
+ ("qt", qt-4)
+ ("quesoglc" ,quesoglc)
+ ("sdl-union" ,(sdl-union))))
+ (home-page "http://wz2100.net")
+ (synopsis "3D Real-time strategy and real-time tactics game")
+ (description
+ "Warzone 2100 offers campaign, multi-player, and single-player skirmish
+modes. An extensive tech tree with over 400 different technologies, combined
+with the unit design system, allows for a wide variety of possible units and
+tactics.")
+ ; Everything is GPLv2+ unless otherwise specified in COPYING.NONGPL
+ (license (list license:bsd-3
+ license:cc0
+ license:cc-by-sa3.0
+ license:expat
+ license:gpl2+
+ license:lgpl2.1+))))