summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-06 16:35:09 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-19 12:16:01 +0200
commitf94bf1983b3da60fdbe176259b19316a547dad07 (patch)
tree44a34a97878006a83ea242f97fdcde5177e78ae3
parent4db9433aa02ced6112170a6815377be3da6d2ef9 (diff)
gnu: Add python-plastid.
* gnu/packages/bioinformatics.scm (python-plastid, python2-plastid): New variables.
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bcb27571a1..1d8011bf79 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -950,6 +950,46 @@ UCSC genome browser.")
(native-inputs `(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+(define-public python-plastid
+ (package
+ (name "python-plastid")
+ (version "0.4.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "plastid" version))
+ (sha256
+ (base32
+ "1nhxw8a5gn9as58i2ih52c5cjwj48ik418pzsjwph3s66mmy9yvq"))))
+ (properties `((python2-variant . ,(delay python2-plastid))))
+ (build-system python-build-system)
+ (arguments
+ ;; Some test files are not included.
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)
+ ("python-pandas" ,python-pandas)
+ ("python-pysam" ,python-pysam)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-biopython" ,python-biopython)
+ ("python-twobitreader" ,python-twobitreader)))
+ (native-inputs
+ `(("python-cython" ,python-cython)
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/joshuagryphon/plastid")
+ (synopsis "Python library for genomic analysis")
+ (description
+ "plastid is a Python library for genomic analysis – in particular,
+high-throughput sequencing data – with an emphasis on simplicity.")
+ (license license:bsd-3)))
+
+(define-public python2-plastid
+ (let ((base (package-with-python2 (strip-python2-variant python-plastid))))
+ (package
+ (inherit base)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))
+
(define-public cd-hit
(package
(name "cd-hit")