summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-06-30 22:45:01 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-30 23:20:34 +0200
commit0fd8013fcaafa9f53c7e304b2573c0314471df89 (patch)
treeebe463909f18ad84e3244dbd62638f542b7d7325
parent66b9183c4f634d9b2ae41176e4eddf0ebb218532 (diff)
gnu: guile-rsvg: Update to commit 05c6a2fd.
* gnu/packages/gtk.scm (guile-rsvg): Update to commit 05c6a2fd. [source](url): Change to gitlab.com. (snippet): Use @GUILE_EFFECTIVE_VERSION@ instead of "2.0". * gnu/packages/patches/guile-rsvg-pkgconfig.patch: Use "$GUILE_EFFECTIVE_VERSION" instead of "2.0".
-rw-r--r--gnu/packages/gtk.scm78
-rw-r--r--gnu/packages/patches/guile-rsvg-pkgconfig.patch2
2 files changed, 43 insertions, 37 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index bb80ef6418..a02e885f56 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -813,43 +813,49 @@ exceptions, macros, and a dynamic programming environment.")
(license license:lgpl3+)))
(define-public guile-rsvg
- (package
- (name "guile-rsvg")
- (version "2.18.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://wingolog.org/pub/guile-rsvg/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "136f236iw3yrrz6pkkp1ma9c5mrs5icqha6pnawinqpk892r3jh7"))
- (patches (search-patches "guile-rsvg-pkgconfig.patch"))
- (modules '((guix build utils)))
- (snippet
- '(substitute* (find-files "." "Makefile\\.am")
- (("/share/guile/site")
- "/share/guile/site/2.0")))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("texinfo" ,texinfo)))
- (inputs `(("guile" ,guile-2.0)
- ("librsvg" ,librsvg)
- ("guile-lib" ,guile2.0-lib))) ;for (unit-test)
- (propagated-inputs `(("guile-cairo" ,guile-cairo)))
- (synopsis "Render SVG images using Cairo from Guile")
- (description
- "Guile-RSVG wraps the RSVG library for Guile, allowing you to render SVG
+ ;; Use a recent snapshot that supports Guile 2.2 and beyond.
+ (let ((commit "05c6a2fd67e4fea1a7c3ff776729dc931bae6678")
+ (revision "0"))
+ (package
+ (name "guile-rsvg")
+ (version (string-append "2.18.1-" revision "."
+ (string-take commit 7)))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/wingo/guile-rsvg/"
+ "repository/archive.tar.gz?ref="
+ commit))
+ (sha256
+ (base32
+ "0vdzjx8l5nc4y2xjqs0g1rqn1zrwfsm30brh5gz00r1x41a2pvv2"))
+ (patches (search-patches "guile-rsvg-pkgconfig.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* (find-files "." "Makefile\\.am")
+ (("/share/guile/site")
+ "/share/guile/site/@GUILE_EFFECTIVE_VERSION@")))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("texinfo" ,texinfo)))
+ (inputs `(("guile" ,guile-2.0)
+ ("librsvg" ,librsvg)
+ ("guile-lib" ,guile2.0-lib))) ;for (unit-test)
+ (propagated-inputs `(("guile-cairo" ,guile-cairo)))
+ (synopsis "Render SVG images using Cairo from Guile")
+ (description
+ "Guile-RSVG wraps the RSVG library for Guile, allowing you to render SVG
images onto Cairo surfaces.")
- (home-page "http://wingolog.org/projects/guile-rsvg/")
- (license license:lgpl2.1+)))
+ (home-page "http://wingolog.org/projects/guile-rsvg/")
+ (license license:lgpl2.1+))))
(define-public guile-present
(package
diff --git a/gnu/packages/patches/guile-rsvg-pkgconfig.patch b/gnu/packages/patches/guile-rsvg-pkgconfig.patch
index 2272b4e1cd..51483a3472 100644
--- a/gnu/packages/patches/guile-rsvg-pkgconfig.patch
+++ b/gnu/packages/patches/guile-rsvg-pkgconfig.patch
@@ -9,7 +9,7 @@ and LDFLAGS for Guile would not be captured.
+dnl The above macro fails to set the 'GUILE_CFLAGS' and 'GUILE_LIBS'
+dnl substitution variables, hence this line.
-+PKG_CHECK_MODULES(GUILE, guile-2.0)
++PKG_CHECK_MODULES(GUILE, guile-$GUILE_EFFECTIVE_VERSION)
+
PKG_CHECK_MODULES(GUILE_CAIRO, guile-cairo >= 1.4.0)
AC_SUBST(GUILE_CAIRO_LIBS)