summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-06-30 00:14:48 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-30 00:16:51 +0200
commit79bfa638295af53ed0c6c325c54f01db84f3b213 (patch)
tree433bdaa2f0f41e89873e5400452672c07294a171
parenta2278922fe5158d3caac9d2c3ff5008e084a45d3 (diff)
maint: Disk image size is automatically guessed.
* Makefile.am (GUIXSD_VM_IMAGE_SIZE): Remove. (release): Remove --image-size argument from 'guix system disk-image' command.
-rw-r--r--Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a5aa2b641..f6059d94bf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -585,9 +585,6 @@ GUIXSD_IMAGE_BASE = guixsd-usb-install-$(PACKAGE_VERSION)
# Prefix of the GuixSD VM image file name.
GUIXSD_VM_IMAGE_BASE = guixsd-vm-image-$(PACKAGE_VERSION)
-# Size of the installation image (for x86_64 typically).
-GUIXSD_INSTALLATION_IMAGE_SIZE ?= 950MiB
-
# Size of the VM image (for x86_64 typically).
GUIXSD_VM_IMAGE_SIZE ?= 2GiB
@@ -635,7 +632,6 @@ release: dist
image=`$(top_builddir)/pre-inst-env \
guix system disk-image \
--system=$$system \
- --image-size=$(GUIXSD_INSTALLATION_IMAGE_SIZE) \
gnu/system/install.scm` ; \
if [ ! -f "$$image" ] ; then \
echo "failed to produced GuixSD installation image for $$system" >&2 ; \