summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-01 22:28:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-04 02:52:25 +0200
commit89fc5b82d46ff5bede7ef4b1e7f5d95dabb92ed6 (patch)
tree034dbe54f70dd1e82667b05edffb0f19b059b700
parent029933cf79daf9faed9160f58f390c3e7384a33e (diff)
gnu: python-cryptography: Update to 1.9.
* gnu/packages/python.scm (python-cryptography-vectors): Update to 1.9. (python-cryptography): Update to 1.9. [propagated-inputs]: Remove PYTHON-PACKAGING.
-rw-r--r--gnu/packages/python.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d1902231b7..5ddb82ed47 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7388,14 +7388,14 @@ responses, rather than doing any computation.")
(define-public python-cryptography-vectors
(package
(name "python-cryptography-vectors")
- (version "1.8.2")
+ (version "1.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography_vectors" version))
(sha256
(base32
- "0hzvq0bfy21bc35p8z7zdxpv3hbvi7adg4axc1b5yd3hk16a1nh0"))))
+ "1wvq1p1viam1diz9x6d61x1bsy6cninv7cjgd35x9ffig9r6gxxv"))))
(build-system python-build-system)
(home-page "https://github.com/pyca/cryptography")
(synopsis "Test vectors for the cryptography package")
@@ -7410,14 +7410,14 @@ responses, rather than doing any computation.")
(define-public python-cryptography
(package
(name "python-cryptography")
- (version "1.8.2")
+ (version "1.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography" version))
(sha256
(base32
- "1nmy4fw3zy7rlvarkhn33g9905rwpy9z7k5kv8j80f0s6ynfp24f"))))
+ "10j8r1s29f4h59kp3mla14g588rm7qpn90nrczijk03i49q3662m"))))
(build-system python-build-system)
(inputs
`(("openssl" ,openssl)))
@@ -7426,12 +7426,6 @@ responses, rather than doing any computation.")
("python-cffi" ,python-cffi)
("python-six" ,python-six)
("python-idna" ,python-idna)
- ;; Packaging is used to check the version of python-cffi in
- ;; 'src/cryptography/hazmat/primitives/ciphers/base.py'. We should be
- ;; able to remove this dependency in the next release of cryptography:
- ;; python-cryptography:
- ;; https://github.com/pyca/cryptography/commit/0417d00d9ff1e19bc3ab67d39bdd18e1674768c1
- ("python-packaging" ,python-packaging)
("python-iso8601" ,python-iso8601)))
(native-inputs
`(("python-cryptography-vectors" ,python-cryptography-vectors)