summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregor Giesen <giesen@zaehlwerk.net>2017-06-24 15:03:47 -0400
committerLeo Famulari <leo@famulari.name>2017-06-30 12:43:40 -0400
commitbf7c36994066feadde81f3a33e42fd6f3767f9b5 (patch)
tree863a3514f152fcbde3aa9df7c96c5aaf47f9ace3
parentecb232bdfcb2718de5944bcf4d9c4e288ec41519 (diff)
gnu: Add nlohmann-json-cpp.
* gnu/packages/serialization.scm (nlohmann-json-cpp): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/serialization.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 6a3d8f900d..6b7461e62b 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
+;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -328,3 +329,25 @@ RPC system. Think JSON, except binary. Or think Protocol Buffers, except faste
convert JSON documents to BSON and the opposite. BSON stands for Binary JSON,
it is comparable to protobuf.")
(license license:asl2.0)))
+
+(define-public nlohmann-json-cpp
+ (package
+ (name "nlohmann-json-cpp")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nlohmann/json/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0lrh6cjd643c7kmvmwafbgq7dqj3b778483gjhjbvp6rc6z5xf2r"))))
+ (build-system cmake-build-system)
+ (home-page "https://nlohmann.github.io/json/")
+ (synopsis "JSON library for C++")
+ (description
+ "JSON library for C++ trying to accomplish “Intuitive syntax”,
+“Trivial integration”, and “Serious testing”.
+However, “Memory efficiency” and “Speed” have not been primary goals.")
+ (license license:expat)))