summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-04 02:38:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-04 02:52:26 +0200
commitde2f56cf96c70d5d3e61809621e71864f5a7f51e (patch)
treef928874420ff09c6569ccadb1e4a6b9e3a8ed263
parent96bbc41f8be5e6bb8483f5ce596db47be271e9e8 (diff)
gnu: python-astroid: Update to 1.5.3.
* gnu/packages/python.scm (python-astroid): Update to 1.5.3. [properties]: Declare python2 variant. (python2-astroid)[propagated-inputs]: Add PYTHON2-BACKPORTS-FUNCTOOLS-LRU-CACHE, PYTHON2-ENUM34 and PYTHON2-SINGLEDISPATCH.
-rw-r--r--gnu/packages/python.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f34f2d39f6..54ab56eeae 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13864,7 +13864,7 @@ users' sessions over extended periods of time.")
(define-public python-astroid
(package
(name "python-astroid")
- (version "1.4.9")
+ (version "1.5.3")
(source
(origin
(method url-fetch)
@@ -13873,7 +13873,7 @@ users' sessions over extended periods of time.")
version ".tar.gz"))
(sha256
(base32
- "0j0wgy54d13a470vm4b9rdjk99n1hmdxpf34x9k3pbmi9w9b566z"))))
+ "0isn5p7f9n48hmksgbrj7dkm9dyglnayzn5jngk37qywg8a74ngn"))))
(build-system python-build-system)
(propagated-inputs
`(("python-lazy-object-proxy" ,python-lazy-object-proxy)
@@ -13898,10 +13898,19 @@ down the AST and building an extended ast. The new node classes have
additional methods and attributes for different usages. They include some
support for static inference and local name scopes. Furthermore, astroid
builds partial trees by inspecting living objects.")
- (license license:lgpl2.1+)))
+ (license license:lgpl2.1+)
+ (properties `((python2-variant . ,(delay python2-astroid))))))
(define-public python2-astroid
- (package-with-python2 python-astroid))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-astroid))))
+ (package (inherit base)
+ (propagated-inputs
+ `(("python2-backports-functools-lru-cache"
+ ,python2-backports-functools-lru-cache)
+ ("python2-enum34" ,python2-enum34)
+ ("python2-singledispatch" ,python2-singledispatch)
+ ,@(package-propagated-inputs base))))))
(define-public python-isort
(package