summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-07-03 13:02:07 +0200
committerRoel Janssen <roel@gnu.org>2017-07-03 13:02:07 +0200
commitfd2d17cdae71eb8bf616d10b9fdbbda6a9d4b644 (patch)
tree2a33bf16f8d942de438f1e1e11b08f14dde4648f
parentbe1033a3349069ee722bf25c804b3bfee4467886 (diff)
gnu: Add emacs-sparql-mode.
* gnu/packages/emacs.scm (emacs-sparql-mode): New variable.
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5177c48a26..a8bf05ca89 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
-;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -3025,6 +3025,27 @@ complement basic functions provided by @code{subr.el}. All provided functions
work on lists, strings and vectors.")
(license license:gpl3+)))
+(define-public emacs-sparql-mode
+ (package
+ (name "emacs-sparql-mode")
+ (version "2.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ljos/sparql-mode/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1s93mkllxnhy7fw616cnnc2danacdlarys0g3cn89drh0llh53cv"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ljos/sparql-mode")
+ (synopsis "SPARQL mode for Emacs")
+ (description "This package provides a major mode for Emacs that provides
+syntax highlighting for SPARQL. It also provides a way to execute queries
+against a SPARQL HTTP endpoint, such as is provided by Fuseki. It is also
+possible to query other endpoints like DBPedia.")
+ (license license:gpl3+)))
+
(define-public emacs-better-defaults
(package
(name "emacs-better-defaults")