summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-24 12:11:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-24 12:11:55 +0300
commit094f4b53af68fb6643a18dd836487224daffdee9 (patch)
treed094df031b7dfd274bed953af407d112a886ae7d
parent2f861edf5cf5118ad560737343312c9a5efe5b2f (diff)
gnu: unionfs-fuse: Enable tests.
* gnu/packages/linux.scm (unionfs-fuse)[arguments]: Replace 'check phase. [native-inputs]: Add python, python-pytest.
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 71e83dfd71..42495a9e4f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1521,8 +1521,16 @@ user-space processes.")
(base32
"0hsn8l1iblvx27bpd4dvnvnbh9ri3sv2f9xzpsnfz3379kb7skgj"))))
(build-system cmake-build-system)
+ (native-inputs
+ `(("python" ,python)
+ ("python-pytest" ,python-pytest)))
(inputs `(("fuse" ,fuse)))
- (arguments '(#:tests? #f)) ; no tests
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ ;; Borrowed from the Makefile
+ (lambda _ (zero? (system* "python3" "-m" "pytest")))))))
(home-page "https://github.com/rpodgorny/unionfs-fuse")
(synopsis "User-space union file system")
(description