summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-27 00:33:06 -0400
committerLeo Famulari <leo@famulari.name>2017-04-27 00:33:06 -0400
commit2018eea07bb00663d2f0cec9d9085d51afa4513b (patch)
treea55ca6062bd1808bdf2d3302b3b3026e6bc5c0f5
parentbe58ffa4aa518686294726bdd83733eca4e6c03c (diff)
parent39d2d9a7abdde28830c39c1128986cad539c081d (diff)
Merge branch 'staging'
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/base.scm6
-rw-r--r--gnu/packages/gl.scm24
-rw-r--r--gnu/packages/gtk.scm12
-rw-r--r--gnu/packages/patches/libdrm-symbol-check.patch25
-rw-r--r--gnu/packages/patches/libsndfile-armhf-type-checks.patch42
-rw-r--r--gnu/packages/patches/mesa-fix-32bit-test-failures.patch58
-rw-r--r--gnu/packages/patches/mesa-skip-disk-cache-test.patch20
-rw-r--r--gnu/packages/pulseaudio.scm40
-rw-r--r--gnu/packages/video.scm4
-rw-r--r--gnu/packages/xdisorg.scm4
-rw-r--r--gnu/packages/xorg.scm25
12 files changed, 176 insertions, 87 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f8a0dd783c..31239933ce 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -714,6 +714,7 @@ dist_patch_DATA = \
%D%/packages/patches/libmad-armv7-thumb-pt2.patch \
%D%/packages/patches/libmad-frame-length.patch \
%D%/packages/patches/libmad-mips-newgcc.patch \
+ %D%/packages/patches/libsndfile-armhf-type-checks.patch \
%D%/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch \
%D%/packages/patches/libtar-CVE-2013-4420.patch \
%D%/packages/patches/libtheora-config-guess.patch \
@@ -779,6 +780,8 @@ dist_patch_DATA = \
%D%/packages/patches/mcrypt-CVE-2012-4409.patch \
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
+ %D%/packages/patches/mesa-fix-32bit-test-failures.patch \
+ %D%/packages/patches/mesa-skip-disk-cache-test.patch \
%D%/packages/patches/mesa-wayland-egl-symbols-check-mips.patch \
%D%/packages/patches/metabat-remove-compilation-date.patch \
%D%/packages/patches/mhash-keygen-test-segfault.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 387ae123ab..9fcca45a54 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1025,7 +1025,7 @@ command.")
(define-public tzdata
(package
(name "tzdata")
- (version "2017a")
+ (version "2017b")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1033,7 +1033,7 @@ command.")
version ".tar.gz"))
(sha256
(base32
- "1mmv4rvcs12lrvgghw4fidczvb69yv69cmzknghcvw1c196mqfnz"))))
+ "11l0s43vx33dcs78p80122i8s5s9l1sjwkzzwh66njd35r92l97q"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f
@@ -1081,7 +1081,7 @@ command.")
version ".tar.gz"))
(sha256
(base32
- "1b1q7gnlsh5hjgs5065pvajd37rmbc3k9b8cgzad1vcrifswdwh2"))))))
+ "0h1d567gn8l3iqgyadcswwdy2yh07nhz3lfl8ds8saz2ajxka5sd"))))))
(home-page "https://www.iana.org/time-zones")
(synopsis "Database of current and historical time zones")
(description "The Time Zone Database (often called tz or zoneinfo)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index bb2eb768ea..40b756394e 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -217,17 +217,21 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "13.0.5")
+ (version "17.0.4")
(source
(origin
(method url-fetch)
- (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
- version "/mesa-" version ".tar.xz"))
+ (uri (list (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
+ "mesa-" version ".tar.xz")
+ (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
+ version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "11zgynii1wz17131ml1mmblpwib8m88zz2jwi5h5llh1r3iagkmz"))
+ "0im3ca1vwwmkjf5w761vh7vabr4vrrdxpckr0wm974x18n2xqs8j"))
(patches
- (search-patches "mesa-wayland-egl-symbols-check-mips.patch"))))
+ (search-patches "mesa-fix-32bit-test-failures.patch"
+ "mesa-wayland-egl-symbols-check-mips.patch"
+ "mesa-skip-disk-cache-test.patch"))))
(build-system gnu-build-system)
(propagated-inputs
`(("glproto" ,glproto)
@@ -281,7 +285,7 @@ also known as DXTn or DXTC) for Mesa.")
;; Without floating point texture support, drivers such as Nouveau
;; are stuck at OpenGL 2.1 instead of OpenGL 3.0+.
"--enable-texture-float"
-
+
;; Also enable the tests.
"--enable-gallium-tests"
@@ -301,7 +305,8 @@ also known as DXTn or DXTC) for Mesa.")
(substitute* "src/compiler/glsl/tests/lower_jumps/create_test_cases.py"
(("/usr/bin/env bash") (which "bash")))
(substitute* "src/intel/genxml/gen_pack_header.py"
- (("/usr/bin/env python2") (which "python")))))
+ (("/usr/bin/env python2") (which "python")))
+ #t))
(add-before
'build 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -325,8 +330,9 @@ also known as DXTn or DXTC) for Mesa.")
;; it's never installed since Mesa removed its
;; egl_gallium support.
(("\"gbm_dri\\.so")
- (string-append "\"" out "/lib/dri/gbm_dri.so")))))))))
- (home-page "http://mesa3d.org/")
+ (string-append "\"" out "/lib/dri/gbm_dri.so")))
+ #t))))))
+ (home-page "https://mesa3d.org/")
(synopsis "OpenGL implementation")
(description "Mesa is a free implementation of the OpenGL specification -
a system for rendering interactive 3D graphics. A variety of device drivers
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f8526053ea..dffa2baf30 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -426,7 +426,7 @@ highlighting and other features typical of a source code editor.")
(define-public gdk-pixbuf
(package
(name "gdk-pixbuf")
- (version "2.36.3")
+ (version "2.36.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -434,7 +434,7 @@ highlighting and other features typical of a source code editor.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1v1rssjd8p5s3lymsfhiq5mbs2pc0h1r6jd0asrwdbrign7i68sj"))
+ "034279k49ydawnagqd7b1rz741n20k4y3grybzwp26zd146bjpj5"))
(patches (search-patches "gdk-pixbuf-list-dir.patch"))))
(build-system gnu-build-system)
(arguments
@@ -653,7 +653,7 @@ application suites.")
(name "gtk+")
;; NOTE: When updating the version of 'gtk+', the hash of 'mate-themes' in
;; mate.scm will also need to be updated.
- (version "3.22.6")
+ (version "3.22.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -661,7 +661,7 @@ application suites.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0bqpx8825b1fdjmz14wq20zq58gq1yi1p5xjps8l6zqid8hmm9zb"))
+ "1359w81sxs2izkan2rni985x78s6zr1arf469qmyw4bazg7f1yl4"))
(patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"
"gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch"))))
(outputs '("out" "bin" "doc"))
@@ -693,9 +693,9 @@ application suites.")
("python-wrapper" ,python-wrapper)
;; By using a special xorg-server for GTK+'s tests, we reduce the impact
;; of updating xorg-server directly on the master branch.
- ("xorg-server" ,xorg-server-1.19.2)))
+ ("xorg-server" ,xorg-server-1.19.3)))
(arguments
- `(#:disallowed-references (,xorg-server-1.19.2)
+ `(#:disallowed-references (,xorg-server-1.19.3)
;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
;; to "doc".
#:configure-flags (list (string-append "--with-html-dir="
diff --git a/gnu/packages/patches/libdrm-symbol-check.patch b/gnu/packages/patches/libdrm-symbol-check.patch
index 69c67e778d..0a77763a4f 100644
--- a/gnu/packages/patches/libdrm-symbol-check.patch
+++ b/gnu/packages/patches/libdrm-symbol-check.patch
@@ -174,26 +174,21 @@ mips64el-linux, armhf-linux and aarch64-linux.
@@ -1,6 +1,6 @@
#!/bin/bash
--# The following symbols (past the first five) are taken from the public headers.
-+# The following symbols (past the first 12) are taken from the public headers.
- # A list of the latter should be available Makefile.sources/LIBDRM_FREEDRENO_H_FILES
+-# The following symbols (past the first nine) are taken from tegra.h.
++# The following symbols (past the first 12) are taken from tegra.h.
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '{print $3}'| while read func; do
-@@ -10,6 +10,13 @@
- _end
- _fini
- _init
+ ( grep -q "^$func$" || echo $func ) <<EOF
+@@ -9,6 +9,9 @@
+ __bss_start
+ __end__
+ _bss_end__
+_fbss
+_fdata
+_ftext
-+__bss_start__
-+__bss_end__
-+_bss_end__
-+__end__
- drm_tegra_bo_get_flags
- drm_tegra_bo_get_handle
- drm_tegra_bo_get_tiling
-
+ _edata
+ _end
+ _fini
--- libdrm-2.4.65/radeon/radeon-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
+++ libdrm-2.4.65/radeon/radeon-symbol-check 2015-10-18 23:57:00.756759698 -0400
@@ -1,6 +1,6 @@
diff --git a/gnu/packages/patches/libsndfile-armhf-type-checks.patch b/gnu/packages/patches/libsndfile-armhf-type-checks.patch
new file mode 100644
index 0000000000..7e0c71c3f6
--- /dev/null
+++ b/gnu/packages/patches/libsndfile-armhf-type-checks.patch
@@ -0,0 +1,42 @@
+This is a regression in 1.0.28 that causes a test failure on armhf.
+
+Upstream bug URL:
+
+https://github.com/erikd/libsndfile/issues/229
+
+Patch copied from upstream source repository:
+
+https://github.com/erikd/libsndfile/commit/9d470ee5577d3ccedb1c28c7e0a7295ba17feaf5
+
+From 9d470ee5577d3ccedb1c28c7e0a7295ba17feaf5 Mon Sep 17 00:00:00 2001
+From: Erik de Castro Lopo <erikd@mega-nerd.com>
+Date: Sun, 16 Apr 2017 17:54:17 +1000
+Subject: [PATCH] src/rf64.c: Fix varargs related bug
+
+C's <stargs.h> functionality isn't type checked so that passing an
+`sf_count_t` (64 bits) by mistake in place of a `unit32_t` can cause
+errors. This would be fine if it was an error on every architecture
+and platform, but its not. This particular problem only manifested
+on armhf and some other Arm architectures. It was not an issue on
+32 bit x86.
+
+I have now fixed variants of this same bug several times.
+
+Closes: https://github.com/erikd/libsndfile/issues/229
+---
+ src/rf64.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/rf64.c b/src/rf64.c
+index b3d637f..02dd904 100644
+--- a/src/rf64.c
++++ b/src/rf64.c
+@@ -742,7 +742,7 @@ rf64_write_header (SF_PRIVATE *psf, int calc_length)
+
+ pad_size = psf->dataoffset - 16 - psf->header.indx ;
+ if (pad_size >= 0)
+- psf_binheader_writef (psf, "m4z", PAD_MARKER, pad_size, make_size_t (pad_size)) ;
++ psf_binheader_writef (psf, "m4z", PAD_MARKER, (unsigned int) pad_size, make_size_t (pad_size)) ;
+
+ if (wpriv->rf64_downgrade && (psf->filelength < RIFF_DOWNGRADE_BYTES))
+ psf_binheader_writef (psf, "tm8", data_MARKER, psf->datalength) ;
diff --git a/gnu/packages/patches/mesa-fix-32bit-test-failures.patch b/gnu/packages/patches/mesa-fix-32bit-test-failures.patch
new file mode 100644
index 0000000000..e21e87cef6
--- /dev/null
+++ b/gnu/packages/patches/mesa-fix-32bit-test-failures.patch
@@ -0,0 +1,58 @@
+Fix a test failure when building for 32 bit architectures:
+
+http://lists.gnu.org/archive/html/guix-devel/2017-04/msg00381.html
+
+Patch copied from upstream source repository:
+
+https://cgit.freedesktop.org/mesa/mesa/commit/?id=61bbb25a080e48a8ca897ba7f6e73cc6a8e9b5b8
+
+From 61bbb25a080e48a8ca897ba7f6e73cc6a8e9b5b8 Mon Sep 17 00:00:00 2001
+From: Grazvydas Ignotas <notasas@gmail.com>
+Date: Thu, 9 Mar 2017 02:54:53 +0200
+Subject: [PATCH] util/disk_cache: fix size subtraction on 32bit
+
+Negating size_t on 32bit produces a 32bit result. This was effectively
+adding values close to UINT_MAX to the cache size (the files are usually
+small) instead of intended subtraction.
+Fixes 'make check' disk_cache failures on 32bit.
+
+Signed-off-by: Grazvydas Ignotas <notasas@gmail.com>
+Reviewed-by: Timothy Arceri <tarceri@itsqueeze.com>
+---
+ src/util/disk_cache.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/util/disk_cache.c b/src/util/disk_cache.c
+index 5470688df3..facdcecf7c 100644
+--- a/src/util/disk_cache.c
++++ b/src/util/disk_cache.c
+@@ -603,7 +603,7 @@ evict_random_item(struct disk_cache *cache)
+ free(dir_path);
+
+ if (size) {
+- p_atomic_add(cache->size, - size);
++ p_atomic_add(cache->size, - (uint64_t)size);
+ return;
+ }
+
+@@ -624,7 +624,7 @@ evict_random_item(struct disk_cache *cache)
+ free(dir_path);
+
+ if (size)
+- p_atomic_add(cache->size, - size);
++ p_atomic_add(cache->size, - (uint64_t)size);
+ }
+
+ void
+#@@ -646,7 +646,7 @@ disk_cache_remove(struct disk_cache *cache, const cache_key key)
+# free(filename);
+#
+# if (sb.st_size)
+#- p_atomic_add(cache->size, - sb.st_size);
+#+ p_atomic_add(cache->size, - (uint64_t)sb.st_size);
+# }
+#
+# /* From the zlib docs:
+--
+2.12.2
+
diff --git a/gnu/packages/patches/mesa-skip-disk-cache-test.patch b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
new file mode 100644
index 0000000000..4377110475
--- /dev/null
+++ b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
@@ -0,0 +1,20 @@
+disk_cache_create() here looks up the users home directory from <pwd.h>
+which resolves to "/" in the build environment. I could not find an easy
+way to set the home directory to something else, so we disable this test
+for now.
+
+--- a/src/compiler/glsl/tests/cache_test.c
++++ b/src/compiler/glsl/tests/cache_test.c
+@@ -137,11 +137,6 @@
+ unsetenv("MESA_GLSL_CACHE_DIR");
+ unsetenv("XDG_CACHE_HOME");
+
+- cache = disk_cache_create();
+- expect_non_null(cache, "disk_cache_create with no environment variables");
+-
+- disk_cache_destroy(cache);
+-
+ /* Test with XDG_CACHE_HOME set */
+ setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
+ cache = disk_cache_create();
+
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index d258c59fa5..c52f265cc1 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;;
@@ -44,15 +45,15 @@
(define-public libsndfile
(package
(name "libsndfile")
- (replacement libsndfile-1.0.28)
- (version "1.0.27")
+ (version "1.0.28")
(source (origin
(method url-fetch)
(uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
version ".tar.gz"))
+ (patches (search-patches "libsndfile-armhf-type-checks.patch"))
(sha256
(base32
- "1h7s61nhf7vklh9sdsbbqzb6x287q4x4j1jc5gmjragl4wprb4d3"))))
+ "1afzm7jx34jhqn32clc5xghyjglccam2728yxlx37yj2y0lkkwqz"))))
(build-system gnu-build-system)
(inputs
`(("libvorbis" ,libvorbis)
@@ -75,31 +76,17 @@ SPARC. Hopefully the design of the library will also make it easy to extend
for reading and writing new sound file formats.")
(license l:gpl2+)))
-(define libsndfile-1.0.28
- (package
- (inherit libsndfile)
- (version "1.0.28")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
- version ".tar.gz"))
- (sha256
- (base32
- "1afzm7jx34jhqn32clc5xghyjglccam2728yxlx37yj2y0lkkwqz"))))))
-
(define-public libsamplerate
(package
(name "libsamplerate") ; aka. Secret Rabbit Code (SRC)
- (replacement libsamplerate-0.1.9)
- (version "0.1.8")
+ (version "0.1.9")
(source (origin
(method url-fetch)
(uri (string-append "http://www.mega-nerd.com/SRC/libsamplerate-"
version ".tar.gz"))
(sha256
(base32
- "01hw5xjbjavh412y63brcslj5hi9wdgkjd3h9csx5rnm8vglpdck"))))
+ "1ha46i0nbibq0pl0pjwcqiyny4hj8lp1bnl4dpxm64zjw9lb2zha"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -125,20 +112,7 @@ against computation cost. The current best converter provides a
signal-to-noise ratio of 145dB with -3dB passband extending from DC to 96% of
the theoretical best bandwidth for a given pair of input and output sample
rates.")
- (license l:gpl2+)))
-
-(define libsamplerate-0.1.9
- (package
- (inherit libsamplerate)
- (version "0.1.9")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://www.mega-nerd.com/SRC/libsamplerate-"
- version ".tar.gz"))
- (sha256
- (base32
- "1ha46i0nbibq0pl0pjwcqiyny4hj8lp1bnl4dpxm64zjw9lb2zha"))))))
+ (license l:bsd-2)))
(define-public pulseaudio
(package
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cc07cc712d..88feac8b1b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -406,7 +406,7 @@ SMPTE 314M.")
(define-public libva
(package
(name "libva")
- (version "1.7.3")
+ (version "1.8.1")
(source
(origin
(method url-fetch)
@@ -414,7 +414,7 @@ SMPTE 314M.")
"https://www.freedesktop.org/software/vaapi/releases/libva/libva-"
version".tar.bz2"))
(sha256
- (base32 "1ndrf136rlw03xag7j1xpmf9015d1h0dpnv6v587jnh6k2a17g12"))))
+ (base32 "0wswfznj93jpnxhc3jwdk5j3pmyki0rs6k9vk4vnzds0dddximf1"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 0467d5b357..8d7f2195c2 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -277,7 +277,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.75")
+ (version "2.4.80")
(source
(origin
(method url-fetch)
@@ -287,7 +287,7 @@ rasterisation.")
".tar.bz2"))
(sha256
(base32
- "0kq5hmck0gq7b29fr8jp94njc7jpkpbyws12s63w4b21xw750nid"))
+ "1wa9cnzf60xwx67zq9ay48xr3j3sn1z80q77jpbzmkg906b52am8"))
(patches (search-patches "libdrm-symbol-check.patch"))))
(build-system gnu-build-system)
(inputs
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 212586fab6..3c9195b1bf 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1095,7 +1095,7 @@ themselves.")
(define-public libpciaccess
(package
(name "libpciaccess")
- (version "0.13.4")
+ (version "0.13.5")
(source
(origin
(method url-fetch)
@@ -1105,7 +1105,7 @@ themselves.")
".tar.bz2"))
(sha256
(base32
- "1krgryi9ngjr66242v0v5mczihgv0y7rrvx0563arr318mjn9y07"))))
+ "16dr80rdw5bzdyhahvilfjrflj7scs2yl2mmghsb84f3nglm8b3m"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)))
@@ -4985,7 +4985,7 @@ over Xlib, including:
(define-public xorg-server
(package
(name "xorg-server")
- (version "1.19.2")
+ (version "1.19.3")
(source
(origin
(method url-fetch)
@@ -4994,7 +4994,7 @@ over Xlib, including:
name "-" version ".tar.bz2"))
(sha256
(base32
- "1fw4b2lf75nsqkiyhn95b1c2if1l3cw5a188a1szx1d8l7sbk2jg"))))
+ "162s1v901djr57gxmmk4airk8hiwcz79dqyz72972x1lw1k82yk7"))))
(build-system gnu-build-system)
(propagated-inputs
`(("dri2proto" ,dri2proto)
@@ -5053,12 +5053,7 @@ over Xlib, including:
("xcb-util-wm" ,xcb-util-wm)))
(native-inputs
`(("python" ,python-minimal-wrapper)
- ("pkg-config" ,pkg-config)
- ;; XXX Bootstrapping inputs for 1.19.2. Remove for > 1.19.2.
- ("font-util" ,font-util)
- ("libtool" ,libtool)
- ("autoconf" ,autoconf)
- ("automake" ,automake)))
+ ("pkg-config" ,pkg-config)))
(arguments
`(#:parallel-tests? #f
#:configure-flags
@@ -5085,10 +5080,6 @@ over Xlib, including:
#:phases
(modify-phases %standard-phases
- ;; XXX The 1.19.2 release of xorg-server was not bootstrapped:
- ;; <https://lists.x.org/archives/xorg-announce/2017-March/002780.html>
- (add-before 'configure 'bootstrap
- (lambda _ (zero? (system* "autoreconf" "-vfi"))))
(add-before
'configure 'pre-configure
(lambda _
@@ -5117,12 +5108,12 @@ draggable titlebars and borders.")
;; This package is intended to be used when building GTK+.
;; Note: It's currently marked as "hidden" to avoid having two non-eq?
;; packages with the same name and version.
-(define-public xorg-server-1.19.2
+(define-public xorg-server-1.19.3
(hidden-package
(package
(inherit xorg-server)
(name "xorg-server")
- (version "1.19.2")
+ (version "1.19.3")
(source
(origin
(method url-fetch)
@@ -5131,7 +5122,7 @@ draggable titlebars and borders.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1fw4b2lf75nsqkiyhn95b1c2if1l3cw5a188a1szx1d8l7sbk2jg")))))))
+ "162s1v901djr57gxmmk4airk8hiwcz79dqyz72972x1lw1k82yk7")))))))
(define-public xorg-server-xwayland
(package