summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-07 13:22:40 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-07 13:25:23 +0800
commit3f7bf86a718b79f0dc17a8d9d1ef90e39f47897a (patch)
treeaae3f22e835f75ef3889cad5d90cf206e3afd608
parentd70a4a5e872aab42ff19d922bffd3b27961cd6e2 (diff)
gnu: Add libiec61883.
* gnu/packages/linux.scm (libiec61883): New variable.
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 637cde9f69..a583e28d24 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2048,3 +2048,27 @@ protocol in question.")
"Libavc1394 is a programming interface to the AV/C specification from
the 1394 Trade Assocation. AV/C stands for Audio/Video Control.")
(license lgpl2.1+)))
+
+(define-public libiec61883
+ (package
+ (name "libiec61883")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kernel.org/linux/libs/ieee1394/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "17ph458zya2l8dr2xwqnzy195qd9swrir31g78qkgb3g4xz2rq6i"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("libraw1394" ,libraw1394))) ; required by libiec61883.pc
+ (home-page "https://ieee1394.wiki.kernel.org/index.php/Main_Page")
+ (synopsis "Isochronous streaming media library for IEEE 1394")
+ (description
+ "The libiec61883 library provides a higher level API for streaming DV,
+MPEG-2 and audio over Linux IEEE 1394.")
+ (license lgpl2.1+)))