summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-19 14:42:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-22 00:36:43 +0200
commit42c939a8591c90ca445254e49728be1ce17addf4 (patch)
tree9ec399eaea04825e6db5afb71dda3aa0e5630681
parentd7e2d273e111796a4c31a6d9974eec494add138f (diff)
gnu: Add python-ipy.
* gnu/packages/networking.scm (python-ipy): New variable.
-rw-r--r--gnu/packages/networking.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cb9903791e..efef2d5a7a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
@@ -1122,6 +1122,24 @@ IPFIX, RSPAN, CLI, LACP, 802.1ag).")
license:bsd-2 license:bsd-3
license:asl2.0)))) ; all other
+(define-public python-ipy
+ (package
+ (name "python-ipy")
+ (version "0.83")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "IPy" version))
+ (sha256
+ (base32
+ "1f6sdrxclifky4gvkf4gvyv5hx3fjh8vzspnfrqki6qm5d9mmnk1"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/autocracy/python-ipy/")
+ (synopsis "Python class and tools for handling IP addresses and networks")
+ (description "The @code{IP} class allows a comfortable parsing and
+handling for most notations in use for IPv4 and IPv6 addresses and
+networks.")
+ (license license:bsd-3)))
+
(define-public speedtest-cli
(package
(name "speedtest-cli")