summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-21 14:25:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-21 15:36:36 +0200
commit833df99d625af91a52bcfc39d2f135f03dd51b37 (patch)
treeffa25ffa6ce4c7a24c2cb3f5db4cc8fb291f5711
parenta7d12a9e71bfffce5d4a3e1106ec97a070d33da7 (diff)
gnu: python-pyopenssl: Update to 17.0.0.
* gnu/packages/python.scm (python-pyopenssl, python2-pyopenssl): Update to 17.0.0. [native-inputs]: Change PYTHON-PYTEST to PYTHON-PYTEST-3.0. * gnu/packages/patches/python-pyopenssl-skip-network-test.patch: Adjust.
-rw-r--r--gnu/packages/patches/python-pyopenssl-skip-network-test.patch25
-rw-r--r--gnu/packages/python.scm6
2 files changed, 12 insertions, 19 deletions
diff --git a/gnu/packages/patches/python-pyopenssl-skip-network-test.patch b/gnu/packages/patches/python-pyopenssl-skip-network-test.patch
index a24eaf69a0..1ac7324c8b 100644
--- a/gnu/packages/patches/python-pyopenssl-skip-network-test.patch
+++ b/gnu/packages/patches/python-pyopenssl-skip-network-test.patch
@@ -7,20 +7,14 @@ diff --git a/tests/test_ssl.py b/tests/test_ssl.py
index ee849fd..60048b8 100644
--- a/tests/test_ssl.py
+++ b/tests/test_ssl.py
-@@ -1180,40 +1180,6 @@ class ContextTests(TestCase, _LoopbackMixin):
- TypeError, context.load_verify_locations, None, None, None
- )
-
-- @pytest.mark.skipif(
-- platform == "win32",
-- reason="set_default_verify_paths appears not to work on Windows. "
-- "See LP#404343 and LP#404344."
-- )
+@@ -1113,33 +1113,6 @@ class TestContext(object):
+ reason="set_default_verify_paths appears not to work on Windows. "
+ "See LP#404343 and LP#404344."
+ )
- def test_set_default_verify_paths(self):
- """
-- :py:obj:`Context.set_default_verify_paths` causes the
-- platform-specific CA certificate locations to be used for
-- verification purposes.
+- `Context.set_default_verify_paths` causes the platform-specific CA
+- certificate locations to be used for verification purposes.
- """
- # Testing this requires a server with a certificate signed by one
- # of the CAs in the platform CA location. Getting one of those
@@ -43,8 +37,7 @@ index ee849fd..60048b8 100644
- clientSSL.set_connect_state()
- clientSSL.do_handshake()
- clientSSL.send(b"GET / HTTP/1.0\r\n\r\n")
-- self.assertTrue(clientSSL.recv(1024))
--
- def test_set_default_verify_paths_signature(self):
+- assert clientSSL.recv(1024)
+
+ def test_add_extra_chain_cert_invalid_cert(self):
"""
- :py:obj:`Context.set_default_verify_paths` takes no arguments and
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index aa014db364..e51405bd9c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7323,14 +7323,14 @@ message digests and key derivation functions.")
(define-public python-pyopenssl
(package
(name "python-pyopenssl")
- (version "16.2.0")
+ (version "17.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyOpenSSL" version))
(sha256
(base32
- "0vji4yrfshs15xpczbhzhasnjrwcarsqg87n98ixnyafnyxs6ybp"))
+ "1pdg1gpmkzj8yasg6cmkhcivxcdp4c12nif88y4qvsxq5ffzxas8"))
(patches
(search-patches "python-pyopenssl-skip-network-test.patch"))))
(build-system python-build-system)
@@ -7348,7 +7348,7 @@ message digests and key derivation functions.")
(inputs
`(("openssl" ,openssl)))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest-3.0)))
(home-page "https://github.com/pyca/pyopenssl")
(synopsis "Python wrapper module around the OpenSSL library")
(description